Secure Main Vps Server

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.tsaris.gr

I ran this command:

It produced this output:

My web server is (include version): VPS with root access

The operating system my web server runs on is (include version): Debian * Jessies

My hosting provider, if applicable, is: Friktoria Servers

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): ISPConfig 3

Hello,
I am operating a vps with multiple vhost. I have succesfully secure each of my vhost I run on this server. Unfortunatelly I have not understand how can I have ssl for my main server.
For example my domain www.tsairis.gr is secured with a certificate. But my main server has the name xxxxxxxx.friktoriaserver.com. I manage it thorugh ispconfig 3. I can not find anywhere in my IspConfig3 a reference to xxxxxx.friktoriaserver.com domain and I need to secure it.

thank you,
Christoforos

What is the purpose of that “main server” domain xxxxxxxx.friktoriaserver.com? Does it actually run a site, or is it some sort of base of operations which is provided by your hosting provider? Does it even run on your VPS, or is it a services ran on a different server of your hosting provider?

My clients run their webmail from https://xxxxx.friktoriaservers.net:8080/webmail and they get e message for insecure connection.
Actualy https://xxxxx.friktoriaservers.net:8080 is my ISPConfig3 installation.

So I need to secure xxxxx.friktoriaservers.net domain somehow.

But who serves the services on that hostname? Does the webmail run from your VPS server?

Yes it runs from vps server

What kind of service/webserver/program listens to port 8080? Is it another instance of Apache or nginx?

as far as I know is IspConfig

ISPconfig isn’t very clear about it in their documentation. There’s one little useful reference to SSL at https://www.faqforge.com/linux/controlpanels/ispconfig3/enable-ssl-for-the-ispconfig-3-controlpanel/

But that’s for older versions of ISPconfig (<3.0.3). It makes a reference to “the ispconfig updater” for newer versions of the software. But there’s no documentation on SSL and the updater specifically. There is however a general FAQ entry for the updater which also mentions SSL: https://www.faqforge.com/linux/controlpanels/ispconfig3/how-to-update-ispconfig-3/

You could try that.

If that doesn’t help you, I’m afraid the Let’s Encrypt forum can’t really help you, because it seems to be an ISPconfig specific issue. Not related to Let’s Encrypt itself or an ACME client we have knowledge of. At least, I don’t… Perhaps you get lucky and someone does have much experience with ISPconfig!

thanks for your time Osiris, from your links I see that you are right. It would be better to ask this question on ISPConfig forums.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.