# Schedule for blocking older cert-manager versions

**URL:** <https://community.letsencrypt.org/t/schedule-for-blocking-older-cert-manager-versions/122926>\
**Category:** Issuance Tech\
**Created:** [May 16, 2020, 3:22pm UTC](https://community.letsencrypt.org/t/schedule-for-blocking-older-cert-manager-versions/122926 "2020-05-16T15:22:45Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![ivanfetch](https://avatars.discourse-cdn.com/v4/letter/i/a6a055/32.png) [@ivanfetch](https://community.letsencrypt.org/u/ivanfetch)\
**Post date:** [May 16, 2020, 3:22pm UTC](https://community.letsencrypt.org/t/schedule-for-blocking-older-cert-manager-versions/122926/1 "2020-05-16T15:22:46Z")

</div>

Related to [this topic](https://community.letsencrypt.org/t/blocking-old-cert-manager-versions/98753) about blocking old cert-manager versions, where is the best place to confirm timing for specific versions of cert-manager being blocked by the API? For example, when will cert-manager 0.8 be blocked by the production API? It appears 0.8 is currently blocked by staging, and will be blocked by production in November 2020?

Thank you all!

---

<div class="post-metadata">

**Author:** ![jsha](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/jsha/32/12_2.png) [@jsha](https://community.letsencrypt.org/u/jsha)\
**Post date:** [May 17, 2020, 6:01pm UTC](https://community.letsencrypt.org/t/schedule-for-blocking-older-cert-manager-versions/122926/2 "2020-05-17T18:01:26Z")

</div>

Things are still the same as when I wrote that post. I don’t think we have 0.8.0 blocked in staging but I can check.

In general though, my advice is still to make sure you are updating cert-manager as soon as you can after each release. There are lots of bugs fixed in each release and as far as I can tell old versions are not supported by the maintainers. It’s not yet the sort of software you can leave on an old version for a long period of time (if indeed any such software exists in this day and age 😄).

---

<div class="post-metadata">

**Author:** ![ivanfetch](https://avatars.discourse-cdn.com/v4/letter/i/a6a055/32.png) [@ivanfetch](https://community.letsencrypt.org/u/ivanfetch)\
**Post date:** [May 18, 2020, 7:46pm UTC](https://community.letsencrypt.org/t/schedule-for-blocking-older-cert-manager-versions/122926/3 "2020-05-18T19:46:25Z")

</div>

> [@jsha](#):
>
> Things are still the same as when I wrote that post. I don’t think we have 0.8.0 blocked in staging but I

Thank you for looking into whether cert-manager 0.8 is being blocked in staging. The error I receive when attempting to issue a cert against the staging API is: ` Reason: Failed to create order: acme: urn:ietf:params:acme:error:malformed: Method not allowed`. I can issue this same cert successfully against the production API.

I agree that best practice is to keep cert-manager updated - we would like to confirm how much time we have to migrate away from v0.8, as we coordinate prerequisites for cert-manager to be upgraded.

Thanks again for your help,

- Ivan

---

<div class="post-metadata">

**Author:** ![jsha](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/jsha/32/12_2.png) [@jsha](https://community.letsencrypt.org/u/jsha)\
**Post date:** [May 18, 2020, 8:00pm UTC](https://community.letsencrypt.org/t/schedule-for-blocking-older-cert-manager-versions/122926/4 "2020-05-18T20:00:24Z")

</div>

> [@ivanfetch](#):
>
> `Failed to create order: acme: urn:ietf:params:acme:error:malformed: Method not allowed` .

Ah, this is a different issue. There was a change late in the ACME standardization process to require POSTs for all ACME requests (previously GETs had been allowed for some requests). [We've started enforcing that in staging](https://community.letsencrypt.org/t/acme-v2-scheduled-deprecation-of-unauthenticated-resource-gets/74380/1) since last year.

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/letsencrypt/original/3X/c/a/ca6c06ea1ea201324bba7048c6841ce60236468d.png) [@system](https://community.letsencrypt.org/u/system)\
**Post date:** [June 17, 2020, 8:00pm UTC](https://community.letsencrypt.org/t/schedule-for-blocking-older-cert-manager-versions/122926/5 "2020-06-17T20:00:29Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
