RHEL 7 (maipo) certbot install fails / python-zope-interface

I’m stuck.

Attempting to install certbot. When I get to the step “yum install cetbot-apache” I get

<>
–> Finished Dependency Resolution
rhel-x86_64-server-7/group | 636 kB 00:00:00
rhel-x86_64-server-7/group | 636 kB 00:00:00
Error: Package: python2-certbot-0.14.1-3.el7.noarch (epel)
Requires: python-zope-interface
Error: Package: 1:python-zope-component-4.1.0-3.el7.noarch (epel)
Requires: python-zope-interface
You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), ‘yum check’ output follows:
ipa-common-4.4.0-14.el7_3.7.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-14.el7_3.7.noarch
ipa-python-compat-4.4.0-14.el7_3.7.noarch has installed conflicts freeipa-python-compat: ipa-python-compat-4.4.0-14.el7_3.7.noarch

I attempted to work around this by using:

pip install zope.event
pip install zope.interface
pip install certbot==0.9.3

But, alas, when I attempt to start certbot I get:

certbot --apache

An unexpected error occurred:
AttributeError: ‘tuple’ object has no attribute 'add’
Please see the logfile ‘certbot.log’ for more details.

Help, please!

can you run pip freeze and let us know what version of certbot was installed

I think one of the versions had an issue with tuples.

Review here: Potential Issue with New Certbot and Argparse - AttributeError: 'tuple' object has no attribute 'add'

BTW: all i did was paste your error message in the search. In future that may save you some time on waiting for someone to reply.

Andrei

pi freeze tells me
certbot==0.9.3

ah ok I should have read your code a bit more

You specified version 0.9.3 - is there a particular reason for this?

Current version is 0.16.0 – i would install using

pip install certbot

and let it get the latest version

Andrei

For that matter, most people who are trying to do some kind of installation outside of their OS package manager would probably be better served by using certbot-auto, an autoupdater created by the Certbot team that’s meant for people who don’t have a working up-to-date operating system package.

1 Like

So… ideally I’d like to get a package manager working, instead of working around it. I was able to resolve the “installed conflicts” with freeipa.

Great. So, now I attempt the yum install certbot-apache command.

#yum install certbot-apache
Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos, subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
Resolving Dependencies
–> Running transaction check
—> Package python2-certbot-apache.noarch 0:0.14.1-1.el7 will be installed
–> Processing Dependency: python2-certbot = 0.14.1 for package: python2-certbot-apache-0.14.1-1.el7.noarch
–> Processing Dependency: certbot = 0.14.1 for package: python2-certbot-apache-0.14.1-1.el7.noarch
–> Processing Dependency: mod_ssl for package: python2-certbot-apache-0.14.1-1.el7.noarch
–> Running transaction check
—> Package certbot.noarch 0:0.14.1-3.el7 will be installed
–> Processing Dependency: /usr/sbin/semanage for package: certbot-0.14.1-3.el7.noarch
–> Processing Dependency: /usr/sbin/semanage for package: certbot-0.14.1-3.el7.noarch
—> Package mod_ssl.x86_64 1:2.4.6-45.el7_3.4 will be installed
—> Package python2-certbot.noarch 0:0.14.1-3.el7 will be installed
–> Processing Dependency: python2-acme = 0.14.1 for package: python2-certbot-0.14.1-3.el7.noarch
–> Processing Dependency: python2-dialog >= 3.3.0 for package: python2-certbot-0.14.1-3.el7.noarch
–> Processing Dependency: python2-configargparse >= 0.10.0 for package: python2-certbot-0.14.1-3.el7.noarch
–> Processing Dependency: python2-future for package: python2-certbot-0.14.1-3.el7.noarch
–> Processing Dependency: python-zope-interface for package: python2-certbot-0.14.1-3.el7.noarch
–> Processing Dependency: python-zope-component for package: python2-certbot-0.14.1-3.el7.noarch
–> Processing Dependency: python-parsedatetime for package: python2-certbot-0.14.1-3.el7.noarch
–> Processing Dependency: python-mock for package: python2-certbot-0.14.1-3.el7.noarch
–> Running transaction check
—> Package policycoreutils-python.x86_64 0:2.5-11.el7_3 will be installed
–> Processing Dependency: libsemanage-python >= 2.5-5 for package: policycoreutils-python-2.5-11.el7_3.x86_64
–> Processing Dependency: setools-libs >= 3.3.8-1 for package: policycoreutils-python-2.5-11.el7_3.x86_64
–> Processing Dependency: audit-libs-python >= 2.1.3-4 for package: policycoreutils-python-2.5-11.el7_3.x86_64
–> Processing Dependency: python-IPy for package: policycoreutils-python-2.5-11.el7_3.x86_64
–> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
–> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
–> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
–> Processing Dependency: checkpolicy for package: policycoreutils-python-2.5-11.el7_3.x86_64
–> Processing Dependency: libapol.so.4()(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
–> Processing Dependency: libqpol.so.1()(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
—> Package python-parsedatetime.noarch 0:1.5-3.el7 will be installed
—> Package python-zope-component.noarch 1:4.1.0-3.el7 will be installed
–> Processing Dependency: python-zope-interface for package: 1:python-zope-component-4.1.0-3.el7.noarch
–> Processing Dependency: python-zope-event for package: 1:python-zope-component-4.1.0-3.el7.noarch
—> Package python2-acme.noarch 0:0.14.1-1.el7 will be installed
–> Processing Dependency: pytz for package: python2-acme-0.14.1-1.el7.noarch
–> Processing Dependency: python-pyrfc3339 for package: python2-acme-0.14.1-1.el7.noarch
–> Processing Dependency: python-ndg_httpsclient for package: python2-acme-0.14.1-1.el7.noarch
—> Package python2-certbot.noarch 0:0.14.1-3.el7 will be installed
–> Processing Dependency: python-zope-interface for package: python2-certbot-0.14.1-3.el7.noarch
—> Package python2-configargparse.noarch 0:0.11.0-1.el7 will be installed
—> Package python2-dialog.noarch 0:3.3.0-6.el7 will be installed
–> Processing Dependency: dialog for package: python2-dialog-3.3.0-6.el7.noarch
—> Package python2-future.noarch 0:0.16.0-2.el7 will be installed
—> Package python2-mock.noarch 0:1.0.1-9.el7 will be installed
–> Running transaction check
—> Package audit-libs-python.x86_64 0:2.6.5-3.el7_3.1 will be installed
—> Package checkpolicy.x86_64 0:2.5-4.el7 will be installed
—> Package dialog.x86_64 0:1.2-4.20130523.el7 will be installed
—> Package libsemanage-python.x86_64 0:2.5-5.1.el7_3 will be installed
—> Package python-IPy.noarch 0:0.75-6.el7 will be installed
—> Package python-ndg_httpsclient.noarch 0:0.3.2-1.el7 will be installed
—> Package python-zope-component.noarch 1:4.1.0-3.el7 will be installed
–> Processing Dependency: python-zope-interface for package: 1:python-zope-component-4.1.0-3.el7.noarch
—> Package python-zope-event.noarch 0:4.0.3-2.el7 will be installed
—> Package python2-certbot.noarch 0:0.14.1-3.el7 will be installed
–> Processing Dependency: python-zope-interface for package: python2-certbot-0.14.1-3.el7.noarch
—> Package python2-pyrfc3339.noarch 0:1.0-2.el7 will be installed
—> Package pytz.noarch 0:2012d-5.el7 will be installed
—> Package setools-libs.x86_64 0:3.3.8-1.1.el7 will be installed
–> Finished Dependency Resolution
rhel-x86_64-server-7/group | 636 kB 00:00:00
rhel-x86_64-server-7/group | 636 kB 00:00:00
Error: Package: python2-certbot-0.14.1-3.el7.noarch (epel)
Requires: python-zope-interface
Error: Package: 1:python-zope-component-4.1.0-3.el7.noarch (epel)
Requires: python-zope-interface
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I tried to overcome the zope-interface issue with the pip commands.

OK… I attempt to start certbot --apache and now I get this “no such extra feature” message

certbot --apache

An unexpected error occurred:
UnknownExtra: requests 2.6.0 has no such extra feature ‘security’

Yeah… I’m floundering here.

Screw it. Using certbot-auto like you said.

That worked. Nothing to see here. Moving along.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.