[resolved] Delay time after renewing?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.whiteboxfitness.com

I ran this command: I forgot.

It produced this output: Mostly forgot. It seemed to have worked, but also said “no module named interface”.

My web server is (include version): Apache

The operating system my web server runs on is (include version): Amazon Linux

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

So my certificate for HTTPS expired and, at the same time, I can no longer use the VPN I had set up. Are these things related, or is it just a coincidence? Anyway, I followed some instructions to renew my certificate, and it seems to have worked, but also gave me some error about “no module named interface”. Now, when I try to go to my site, it still doesn’t have HTTPS. Does this mean that it didn’t work, or is there just a delay for it to take effect. If so, about how long is the delay? Thanks.

try looking for the original command:
history | grep cert | more

if found, show command
not a big deal if you can’t find it

in any case, look for cli.ini file
if found show content
if not found, look for /etc/letsencrypt/renewal/<your.cert.name>.conf and show contents

this is all in an attempt to repeat something that we know already worked.
but if all else fails, we can still figure out something (all over again - if needed)

I see your cert expired 6 days ago…
sudo certbot-auto
or if certbot-auto is not found
sudo certbot --version
(post that to this thread)
and then also run
sudo certbot


It’s a little convoluted because I wasn’t sure if it worked so I tried multiple things.

I don’t know how to find cli.ini file. What directory would it be in?

(image missing. see below)

(image missing. see below)

cd /
find / -name cli.ini

but go ahead and try
sudo ./certbot-auto
but based on the history it looks like you tried it recently
after it fails (again), show /var/log/letsencrypt/letsencrypt.log


0.15.0 is not bad but 0.19.0 just came out
you can see it (in green)
just add the dot slash to run it
sudo ./certbot-auto


sudo ./certbot-auto
and then show
more /var/log/letsencrypt/letsencrypt.log

It says “command not found”. Did you see the last image?


OK, find it - I know it’s there somewhere:
cd /
find / -name certbot-auto

then run the full path and file name


seems broken

Do you use python2.7?
Or did certbot-auto install it?

wait there is also "certbot-auto.1"
ls -l certb*

I think I installed python 2.7.

certbot-auto.1 is a duplicate because I ran wget twice.

at this point, I would

  1. remove python2.7
    apt-get remove python2.7
  2. rerun certbot-auto
    sudo ./certbot-auto

cerbot should replace any/all dependancies, update itself and just run.

but I’ve been known to shoot first…
do you use python2.7 for anything else?

history | grep python

No I don’t use Python for anything else. Having trouble removing it:


sudo apt-get remove python2.7

Does that have to be run from a certain folder?