# requests.exceptions.ConnectionError: HTTPSConnectionPool

**URL:** https://community.letsencrypt.org/t/requests-exceptions-connectionerror-httpsconnectionpool/186452
**Category:** Help
**Created:** [October 20, 2022, 7:34pm UTC](https://community.letsencrypt.org/t/requests-exceptions-connectionerror-httpsconnectionpool/186452 "2022-10-20T19:34:09Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![BenLue](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/benlue/32/64934_2.png) [@BenLue](https://community.letsencrypt.org/u/BenLue)
#### Post date: [October 20, 2022, 7:34pm UTC](https://community.letsencrypt.org/t/requests-exceptions-connectionerror-httpsconnectionpool/186452/1 "2022-10-20T19:34:09Z")

</div>

Hmmm, is my IP 82.64.255.8 & 193.70.114.98 blocked?

requests.exceptions.ConnectionError: HTTPSConnectionPool(host='[acme-v02.api.letsencrypt.org](http://acme-v02.api.letsencrypt.org)', port=443): Max retries exceeded with url: /directory (Caused by NewConnectionError('\<urllib3.connection.HTTPSConnection object at 0xffffb13004e0\>: Failed to establish a new connection: [Errno -3] Temporary failure in name resolution'))  
Ask for help or search for solutions at [https://community.letsencrypt.org](https://community.letsencrypt.org). See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

letsencrypt.log: [debian Pastezone](https://paste.debian.net/1257768/)

i hope somone can help me.

---

<div class="post-metadata">

### Author: ![Osiris](https://avatars.discourse-cdn.com/v4/letter/o/839c29/32.png) [@Osiris](https://community.letsencrypt.org/u/Osiris)
#### Post date: [October 20, 2022, 7:36pm UTC](https://community.letsencrypt.org/t/requests-exceptions-connectionerror-httpsconnectionpool/186452/2 "2022-10-20T19:36:03Z")

</div>

> [@BenLue](#):
>
> Temporary failure in name resolution

Please fix the DNS resolving capabilities of the host running Certbot. The error points to a DNS resolving problem.

Also, perhaps it's a good idea to edit the title of your thread to something better suited: the URI of an unrelated issue is probably not the best one.

---

<div class="post-metadata">

### Author: ![BenLue](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/benlue/32/64934_2.png) [@BenLue](https://community.letsencrypt.org/u/BenLue)
#### Post date: [October 20, 2022, 7:56pm UTC](https://community.letsencrypt.org/t/requests-exceptions-connectionerror-httpsconnectionpool/186452/3 "2022-10-20T19:56:50Z")

</div>

Thanks for your reply. The Host ist running under debian vm -\> docker -\> nginx proxy manager.  
container network: bridge

i have forwarded the port 80&443 to my debian vm. The Domain npm.s3-dev.ovh was added under pi-hole DNS and Cloudflare. I have no clue why i get an dns problem ☹

---

<div class="post-metadata">

### Author: ![Osiris](https://avatars.discourse-cdn.com/v4/letter/o/839c29/32.png) [@Osiris](https://community.letsencrypt.org/u/Osiris)
#### Post date: [October 20, 2022, 8:05pm UTC](https://community.letsencrypt.org/t/requests-exceptions-connectionerror-httpsconnectionpool/186452/4 "2022-10-20T20:05:02Z")

</div>

It's a generic DNS problem: your container running Certbot probably can't resolve _any_ host. (E.g., the command `ping google.com` would probably fail too..) Please search for Docker and DNS issues on the internet (I'm not familiair with the workings of Docker myself). Or just search for the error "Temporary failure in name resolution" on this Community.

---

<div class="post-metadata">

### Author: ![BenLue](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/benlue/32/64934_2.png) [@BenLue](https://community.letsencrypt.org/u/BenLue)
#### Post date: [October 21, 2022, 6:25pm UTC](https://community.letsencrypt.org/t/requests-exceptions-connectionerror-httpsconnectionpool/186452/5 "2022-10-21T18:25:50Z")

</div>

Ping is working! Now i get this msg ☹

[10/21/2022] [6:23:26 PM] [Express] › ⚠ warning Command failed: certbot certonly --config "/etc/letsencrypt.ini" --cert-name "npm-12" --agree-tos --authenticator webroot --email "benlue@s3root.ovh" --preferred-challenges "dns,http" --domains "npm.s3-dev.ovh"  
Saving debug log to /var/log/letsencrypt/letsencrypt.log  
An unexpected error occurred:  
There were too many requests of a given type :: Error creating new order :: too many failed authorizations recently: see [Failed Validation Limit - Let's Encrypt](https://letsencrypt.org/docs/failed-validation-limit/)  
Ask for help or search for solutions at [https://community.letsencrypt.org](https://community.letsencrypt.org). See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

---

<div class="post-metadata">

### Author: ![Osiris](https://avatars.discourse-cdn.com/v4/letter/o/839c29/32.png) [@Osiris](https://community.letsencrypt.org/u/Osiris)
#### Post date: [October 21, 2022, 6:30pm UTC](https://community.letsencrypt.org/t/requests-exceptions-connectionerror-httpsconnectionpool/186452/6 "2022-10-21T18:30:20Z")

</div>

> [@BenLue](#):
>
> Error creating new order :: too many failed authorizations recently

That means you've tried too many times and failed. See the linked rate limit page for how long you're limited.

Unfortunately, this error also obfuscates the _actual_ error what's causing the validation to fail to begin with.

You should switch to the staging environment and debug why the challenge is failing. Only when the challenge is succeeding, you should change back to the production environment to get your cert.

---

<div class="post-metadata">

### Author: ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)
#### Post date: [October 21, 2022, 6:33pm UTC](https://community.letsencrypt.org/t/requests-exceptions-connectionerror-httpsconnectionpool/186452/7 "2022-10-21T18:33:46Z")

</div>

I see:

> [@BenLue](#):
>
> `--authenticator webroot`

But no specific web root path is being provided.

---

<div class="post-metadata">

### Author: ![BenLue](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/benlue/32/64934_2.png) [@BenLue](https://community.letsencrypt.org/u/BenLue)
#### Post date: [October 21, 2022, 7:24pm UTC](https://community.letsencrypt.org/t/requests-exceptions-connectionerror-httpsconnectionpool/186452/8 "2022-10-21T19:24:46Z")

</div>

i use Nginx Proxy Manager: [http://npm.s3-dev.ovh/login](http://npm.s3-dev.ovh/login)

---

<div class="post-metadata">

### Author: ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)
#### Post date: [October 21, 2022, 7:28pm UTC](https://community.letsencrypt.org/t/requests-exceptions-connectionerror-httpsconnectionpool/186452/9 "2022-10-21T19:28:00Z")

</div>

There lies part of the problem:  
`NPM` is difficult to troubleshoot.

---

<div class="post-metadata">

### Author: ![Osiris](https://avatars.discourse-cdn.com/v4/letter/o/839c29/32.png) [@Osiris](https://community.letsencrypt.org/u/Osiris)
#### Post date: [October 21, 2022, 7:48pm UTC](https://community.letsencrypt.org/t/requests-exceptions-connectionerror-httpsconnectionpool/186452/10 "2022-10-21T19:48:43Z")

</div>

npm is just terrible.

---

<div class="post-metadata">

### Author: ![system](https://global.discourse-cdn.com/letsencrypt/original/3X/c/a/ca6c06ea1ea201324bba7048c6841ce60236468d.png) [@system](https://community.letsencrypt.org/u/system)
#### Post date: [November 20, 2022, 7:48pm UTC](https://community.letsencrypt.org/t/requests-exceptions-connectionerror-httpsconnectionpool/186452/11 "2022-11-20T19:48:55Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
