Renewing a certificate doesn't update the website conf

When I first created my certificates, it created a parallel ssl-conf of all my webpages in /etc/apache2/sites-available/. Now I have updated the original nextcloud.conf and ran certbot again, but that did not update the nextcloud-le-ssl.conf. This lead to me debugging for hours because apache gave me errors - until I finally found out that my configuration changes simply didn’t get through.
Is there a commandline argument for refreshing this? How is this supposed to go? Am I doing something incorrectly?

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

Hi @xerus

there is no need to update that config file.

The config file has some paths and file names. These are symlinks.

Creating a new certificate Certbot doesn’t change these paths and file names. Instead, the symlink is changed.

So an Apache restart is enough to use a new certificate.

Because I changed some paths, I had to update that config file. I don’t think we are talking about the same thing here.

Hi @xerus,

You might be able to get the result you want by deleting the -le-ssl.conf file in /etc/apache2/sites-available and /etc/apache2/sites-enabled and then running sudo certbot install. This should create a new HTTPS virtual host based on the existing HTTP virtual host.

What we’d normally anticipate is that Certbot users would make their HTTP virtual host redirect to the HTTPS site, and thereafter do all of the main site configuration in the HTTPS virtual host configuration file.

If you’re going to delete your -le-ssl.conf files in order to try this, I would strongly suggest making a backup of them in another directory so that you don’t lose information in case my suggestion doesn’t achieve the result you were expecting.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.