# Renewed My Cert, But Still Have Error in Browser About Invalid Response and Such

**URL:** <https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303>\
**Category:** Help\
**Created:** [July 16, 2022, 12:47am UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303 "2022-07-16T00:47:17Z")\
**Posts on this page:** 20\
**Page:** 3

<div class="post-metadata">

**Author:** ![Nummer378](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/nummer378/32/49862_2.png) [@Nummer378](https://community.letsencrypt.org/u/Nummer378)\
**Post date:** [July 19, 2022, 5:51pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/41 "2022-07-19T17:51:32Z")

</div>

> [@DragonOsman](#):
>
> [Tue Jul 19 22:42:27 PKT 2022] [dragonosman.dynu.net](http://dragonosman.dynu.net):Verify error:39.48.202.121: Fetching [http://dragonosman.dynu.net/.well-known/acme-challenge/ktJanzjrVeTDiIl-eHAw7VMCqVVcZvLvtK7OUH1S-6M:](http://dragonosman.dynu.net/.well-known/acme-challenge/ktJanzjrVeTDiIl-eHAw7VMCqVVcZvLvtK7OUH1S-6M:) Timeout during connect (likely firewall problem)

This is the error message reported by Let's Encrypt. It means that Let's Encrypts servers were unable to connect to your server, with the connection timing out.

From my machine, I have the same issue - there is no answer from your port 80. This may be related to firewalls, or port forwarding issues.

---

<div class="post-metadata">

**Author:** ![DragonOsman](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/dragonosman/32/30332_2.png) [@DragonOsman](https://community.letsencrypt.org/u/DragonOsman)\
**Post date:** [July 19, 2022, 5:54pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/42 "2022-07-19T17:54:28Z")

</div>

I've setup port forwarding on port 5501 on my computer for the app. Port 80 should still be closed. Should I tell it to use port 5501?

The server doesn't have to be running, does it? Because it's not atm.

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [July 19, 2022, 5:55pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/43 "2022-07-19T17:55:24Z")

</div>

> [@Nummer378](#):
>
> From my machine, I have the same issue - there is no answer from your port 80

> [@DragonOsman](#):
>
> ./acme.sh --issue --standalone -d [dragonosman.dynu.net](http://dragonosman.dynu.net) --debug

There is only a very small window of "accessibility" with `--standalone` ☹  
[very difficult for testing]

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [July 19, 2022, 5:56pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/44 "2022-07-19T17:56:20Z")

</div>

> [@DragonOsman](#):
>
> Port 80 should still be closed.

You need to allow port 80 in, so that `acme-sh` can respond.

---

<div class="post-metadata">

**Author:** ![DragonOsman](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/dragonosman/32/30332_2.png) [@DragonOsman](https://community.letsencrypt.org/u/DragonOsman)\
**Post date:** [July 19, 2022, 5:59pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/45 "2022-07-19T17:59:32Z")

</div>

It worked before and I haven't done anything to port 80 since then. Do I need to forward it, or do I just need to change firewall settings?

And I'm using `--standalone` because I'm trying to run my own server app rather than one from nginx, Apache, or any other known vendor.

---

<div class="post-metadata">

**Author:** ![Osiris](https://avatars.discourse-cdn.com/v4/letter/o/839c29/32.png) [@Osiris](https://community.letsencrypt.org/u/Osiris)\
**Post date:** [July 19, 2022, 6:00pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/46 "2022-07-19T18:00:51Z")

</div>

Is the IP address of your server correctly set in DNS? Currently it's `39.48.202.121`. You can check by running `curl -4 ifconfig.co` on the server.

---

<div class="post-metadata">

**Author:** ![DragonOsman](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/dragonosman/32/30332_2.png) [@DragonOsman](https://community.letsencrypt.org/u/DragonOsman)\
**Post date:** [July 19, 2022, 6:01pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/47 "2022-07-19T18:01:51Z")

</div>

How do I check if it's set in DNS?

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [July 19, 2022, 6:02pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/48 "2022-07-19T18:02:30Z")

</div>

> [@Osiris](#):
>
> You can check by running **`curl -4 ifconfig.co`** on the server.

DNS is set to:

> [@Osiris](#):
>
> Currently it's **`39.48.202.121`**

---

<div class="post-metadata">

**Author:** ![DragonOsman](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/dragonosman/32/30332_2.png) [@DragonOsman](https://community.letsencrypt.org/u/DragonOsman)\
**Post date:** [July 19, 2022, 6:04pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/49 "2022-07-19T18:04:12Z")

</div>

Do you mean I need to run that command in app root directory? Or do I pass in the web root as an argument somehow?

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [July 19, 2022, 6:10pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/50 "2022-07-19T18:10:44Z")

</div>

Do you have CLI access?

---

<div class="post-metadata">

**Author:** ![DragonOsman](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/dragonosman/32/30332_2.png) [@DragonOsman](https://community.letsencrypt.org/u/DragonOsman)\
**Post date:** [July 19, 2022, 6:11pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/51 "2022-07-19T18:11:43Z")

</div>

It's a C++ web server app that I run on the Command Prompt, so I'd hazard a guess and say yes.

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [July 19, 2022, 6:15pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/52 "2022-07-19T18:15:08Z")

</div>

> [@DragonOsman](#):
>
> Command Prompt

Windows?

---

<div class="post-metadata">

**Author:** ![DragonOsman](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/dragonosman/32/30332_2.png) [@DragonOsman](https://community.letsencrypt.org/u/DragonOsman)\
**Post date:** [July 19, 2022, 6:15pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/53 "2022-07-19T18:15:29Z")

</div>

Of course. Though I also have WSL2.

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [July 19, 2022, 6:16pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/54 "2022-07-19T18:16:27Z")

</div>

hmm...  
OK, well then the "same way" you run "`./acme-sh ...`", then do:  
`curl -4 ifconfig.co`

---

<div class="post-metadata">

**Author:** ![DragonOsman](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/dragonosman/32/30332_2.png) [@DragonOsman](https://community.letsencrypt.org/u/DragonOsman)\
**Post date:** [July 19, 2022, 6:19pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/55 "2022-07-19T18:19:29Z")

</div>

Try again to issue a cert, then run the curl command?

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [July 19, 2022, 6:21pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/56 "2022-07-19T18:21:41Z")

</div>

No, just the `curl`  
[do it the same way though]

---

<div class="post-metadata">

**Author:** ![DragonOsman](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/dragonosman/32/30332_2.png) [@DragonOsman](https://community.letsencrypt.org/u/DragonOsman)\
**Post date:** [July 19, 2022, 6:23pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/57 "2022-07-19T18:23:19Z")

</div>

39.48.202.121

So yeah, that's the public IP address. How do I know if it's stored in DNS? Or is it the command's output _because_ it's stored in DNS?

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [July 19, 2022, 6:24pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/58 "2022-07-19T18:24:09Z")

</div>

> [@DragonOsman](#):
>
> How do I know if it's stored in DNS?

`nslookup dragonosman.dynu.net`  
`dig dragonosman.dynu.net +short`

---

<div class="post-metadata">

**Author:** ![DragonOsman](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/dragonosman/32/30332_2.png) [@DragonOsman](https://community.letsencrypt.org/u/DragonOsman)\
**Post date:** [July 19, 2022, 6:25pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/59 "2022-07-19T18:25:47Z")

</div>

> nslookup [dragonosman.dynu.net](http://dragonosman.dynu.net)  
> Server: 172.19.224.1  
> Address: 172.19.224.1#53
> 
> Non-authoritative answer:  
> Name: [dragonosman.dynu.net](http://dragonosman.dynu.net)  
> Address: 39.48.202.121  
> Name: [dragonosman.dynu.net](http://dragonosman.dynu.net)  
> Address: ::5501

and

> dig [dragonosman.dynu.net](http://dragonosman.dynu.net) +short  
> 39.48.202.121

---

<div class="post-metadata">

**Author:** ![Osiris](https://avatars.discourse-cdn.com/v4/letter/o/839c29/32.png) [@Osiris](https://community.letsencrypt.org/u/Osiris)\
**Post date:** [July 19, 2022, 6:28pm UTC](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303/60 "2022-07-19T18:28:33Z")

</div>

So an incorrect DNS is not the issue here, let's move on.

[Previous page](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303.md?page=2)

[Next page](https://community.letsencrypt.org/t/renewed-my-cert-but-still-have-error-in-browser-about-invalid-response-and-such/181303.md?page=4)
