Renewed certificate for my website hosted in Gitlab Pages isn't getting updated!


#1

Please fill out the fields below so we can help you better.

My domain is: jikkujose.in

I ran this command: sudo certbot certonly -a manual -d jikkujose.in

It produced this output: Asked me to update the site with a file with specific name & contents. Did it, it worked. Got certificates.

My operating system is (include version): Mac OSX 10.11.6

My web server is (include version): Gitlab Pages

My hosting provider, if applicable, is: Gitlab Pages

I can login to a root shell on my machine (yes or no, or I don’t know): No

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Using their settings pages; the certificate is updated there!

More: I have deleted the old certificate & added the new one. It shows up in settings page, but its not updated.


#2

Not updated where?

Is the live site serving your old cert?


#3

Hello @JikkuJose,

I don’t use Gitlab Pages so I don’t know how it works but keep in mind that the web server that is serving your web site must be reloaded/restarted so the new cert would be applied.

Cheers,
sahsanu


#4

So, its likely that I need to contact GitLab for this?


#5

Hi @JikkuJose,

Well, the procedure should be the same as the first time you installed the certificate, I don’t know if you had to use any option from Gitlab control panel (or whatever it uses) but yes, you should contact Gitlab support and they will guide you through the righ procedure to reload your new cert.

Good luck,
sahsanu


#6

Did you contact?
What did they say?


#7

I didn’t have to, there was some delay in getting in done. That’s all


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.


I renewed my certificate but browsers don't know there is a new certificate for this website