Renewal Gone Wrong - can't access site

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: nativeneil.com

I ran this command:
sudo /opt/bitnami/letsencrypt/lego --email="taylornd@gmail.com" --domains=nativeneil.com --domains=www.nativeneil.com --domains=ndntaylor.com --domains=www.ndntaylor.com --path="/opt/bitnami/letsencrypt" renew

It produced this output:
Ran fine but can't access site anymore

My web server is (include version):
Google Cloud Bitnami WordPress

The operating system my web server runs on is (include version):
bitnami-wordpress-5-0-2-1-linux-debian-9-x86-64

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):
yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
lego

What do you mean by "can't access site anymore"? What error do you get? Timeout? Certificate errors?

May be a dumb question, but did you restart the bitnami services after renewing the certificate?

504 time out and the certificate gets an error about the name not matching the input.

Yes I did restart the server thanks.

Strange as I copy and paste the same ssh commands every 60 days!

Hi @nativeneil

checking your domain via https://check-your-website.server-daten.de/?q=nativeneil.com - there is a https timeout (10 seconds).

Checking with my browser - there is the 504:

Gateway Timeout

The gateway did not receive a timely response from the upstream server or application.

But: The certificate is valid, with 4 domain names, valid 2021-03-30.

So certificate creation and installation had worked.

504 is only an internal server error, your proxy logic doesn't work -> fix that.

PS:

D:\temp>download https://nativeneil.com/ -h
SystemDefault
SSL-Zertifikat is valide
Error (1): Timeout für Vorgang überschritten
Timeout
5

60061,61 milliseconds
60,06 seconds

1 Like

Thanks @JuergenAuer - any tips on where to get started with proxy logic?
Everything worked ok yesterday before I updated the certificates.

1 Like

Solved - something was eating up hard dive space. Cleared cache and works fine now

2 Likes

Happy to read you have found the problem :+1:

Such 5** errors are normally individual local problems.

2 Likes