Renewal Failure - unexpected error


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: kidscenterky.org

I ran this command: /etc/nginx/letsencrypt/certbot-auto renew --allow-subset-of-name

It produced this output:

-> ------------------------------------------------------------------------------

Processing /etc/letsencrypt/renewal/kidscenterky.org.conf

Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for kidscenterky.org
http-01 challenge for www.kidscenterky.org
Waiting for verification…
Challenge failed for domain kidscenterky.org
Challenge failed for domain www.kidscenterky.org
Cleaning up challenges
Attempting to renew cert (kidscenterky.org) from /etc/letsencrypt/renewal/kidscenterky.org.conf produced an unexpected error: Challenges failed for all domains. Skipping.

My web server is (include version):

nginx/1.10.3 (Ubuntu)

The operating system my web server runs on is (include version):

Ubuntu 16.04LTS

My hosting provider, if applicable, is: self host Rackspace cloud server

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

Additional stuff:

The original cert was via DNS: with this config:

Options used in the renewal process

[renewalparams]
authenticator = manual
installer = None
account = c316e73462814f2026ccaacd39596bf3
pref_challs = dns-01,
manual_public_ip_logging_ok = True

With this config, I get this (different) error during renewal:


Processing /etc/letsencrypt/renewal/kidscenterky.org.conf

Cert is due for renewal, auto-renewing…
Could not choose appropriate plugin: The manual plugin is not working; there may be problems with your existing configuration.
The error was: PluginError(‘An authentication script must be provided with --manual-auth-hook when using the manual plugin non-interactively.’,)
Attempting to renew cert (kidscenterky.org) from /etc/letsencrypt/renewal/kidscenterky.org.conf produced an unexpected error: The manual plugin is not working; there may be problems with your existing configuration.
The error was: PluginError(‘An authentication script must be provided with --manual-auth-hook when using the manual plugin non-interactively.’,). Skipping.

Which does not help me. So now that we control the DNS, I tried to manually switch it to webroot, using this config:

Options used in the renewal process

[renewalparams]
authenticator = webroot
installer = None
account = c316e73462814f2026ccaacd39596bf3
webroot_path = /home/clients/kidscenterky.org/htdocs,
[[webroot_map]]
www.kidscenterky.org = /home/clients/kidscenterky.org/htdocs
kidscenterky.org = /home/clients/kidscenterky.org/htdocs

And now getting the error at the top of this post.

Thanks.


#2

Hi @hal1

there is a comma at the end. Looks wrong.


#3

Thanks. Same error, with or without comma. I actually had that from copying an existing, working webroot config. I thought it was odd indeed, but that config worked.


#4

Dooooon’t use that option unless you want Certbot to permanently drop domains that fail validation once due to some sort of temporary outage.

Are you sure the web root is correct? What’s in the web server’s log? What’s in /var/log/letsencrypt/letsencrypt.log?


#5

That was there indeed for domains that have physically moved somewhere else.

Thank you, removing that though, got me a different error message which made more sense to me, and led me to find that our default nginx config blocks all dotfiles and directories.

Domain: kidscenterky.org
Type: unauthorized
Detail: Invalid response from
http://kidscenterky.org/.well-known/acme-challenge/B_aEcH1ssdAW_OF2VQhUKSZjPPfUgC8j1pV5FHgjeRU:
"

403 Forbidden

403 Forbidden


"

Thanks again!


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.