Renewal fails, not getting expiration notification

My domain is:

I ran this command

sh getssl $domain

It produced this output:

Verify error:json was blank

My web server is (include version):


The operating system my web server runs on is (include version):


My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):


getssl is at v2.14, apparently there is a v2.15 available within the last hour or so that addresses (mentions) this issue. However, it appears the actual script is still 2.14 at least via their upgrade process.

Any help here?

1 Like

Well, that’s (I think) there hasn’t been an actual release since 2.14 yet. So the new changes aren’t yet in “production”.

However, getssl is a single bash script, so you could download the script from and upgrade it manually.

1 Like

I think I managed that using their suggested curl command. However, I still get errors.
get an error at the end saying “Verify error:”

Only key and csr file get created.

running it in debug and sending text to file see this:
“response not in json format
response status = valid”

where it is attempting the “challenge” with the ACME

That is the end of the text it output. I can post the entire thing if you wish.

1 Like

What is most frustrating about this is the certs have expired as I am still not being notified of expiry approaching.

I wrestled with this a couple months back and was not successful, apparently.

Had noted the dates, but, things get in the way.

1 Like

Hi joea,

Apologies for the problems you had with getssl (I’m one of the maintainers) - I accidentally left 2.15 as a draft release. I’m just fixing some issues I’ve found on Alpine linux with newer versions of gawk and should be releasing 2.17 towards the end of this week.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.