Renew via DNS01 fails with: Caused by: org.shredzone.acme4j.exception.AcmeServerException: No order for ID 1157210309

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: eenfach.de

I ran this command:
java -jar acme_client.jar --command verify-domains -a /etc/pjac/account.key -w /etc/pjac/workdir/ -c /etc/pjac/eenfach.de.csr --challenge-type DNS01

It produced this output:
Exception in thread “main” org.shredzone.acme4j.exception.AcmeLazyLoadingException: Order https://acme-v02.api.letsencrypt.org/acme/order/67299589/1157210309
at org.shredzone.acme4j.AcmeJsonResource.getJSON(AcmeJsonResource.java:68)
at org.shredzone.acme4j.Order.getAuthorizations(Order.java:107)
at com.jblur.acme_client.command.certificate.VerifyDomainsCommand.commandExecution(VerifyDomainsCommand.java:51)
at com.jblur.acme_client.command.ACMECommand.execute(ACMECommand.java:47)
at com.jblur.acme_client.CommandExecutor.executeACMECommand(CommandExecutor.java:123)
at com.jblur.acme_client.CommandExecutor.execute(CommandExecutor.java:74)
at com.jblur.acme_client.Application.main(Application.java:65)
Caused by: org.shredzone.acme4j.exception.AcmeServerException: No order for ID 1157210309
at org.shredzone.acme4j.connector.DefaultConnection.throwAcmeException(DefaultConnection.java:490)
at org.shredzone.acme4j.connector.DefaultConnection.performRequest(DefaultConnection.java:417)
at org.shredzone.acme4j.connector.DefaultConnection.sendSignedRequest(DefaultConnection.java:346)
at org.shredzone.acme4j.connector.DefaultConnection.sendSignedPostAsGetRequest(DefaultConnection.java:147)
at org.shredzone.acme4j.AcmeJsonResource.update(AcmeJsonResource.java:119)
at org.shredzone.acme4j.AcmeJsonResource.getJSON(AcmeJsonResource.java:63)
… 6 more

My web server is (include version):
Apache/2.4.41 (Unix) OpenSSL/1.1.1d

The operating system my web server runs on is (include version):
Solaris 11.3/sparc

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

(1656) toy:/root/acme# java -jar acme_client.jar --version
Porunov Java ACME Client (PJAC) v3.0.1

1 Like

Hi @olbohlen

I don’t know how that client works. But Plesk had a bug with the same error message.

So first step: Check, if there is an update of that client.

1 Like

Thanks, I’ll check back.

For future googles:

The client has an “order list” locally and it seems in the list was an old/invalid order. I removed that one and it seemed to solve the issue. No idea (yet) if it is a bug or due to a mis-usage of the client.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.