Renew my certificate to support NAS access


#1

I am a novice at this stuff. I loaded a Let’sencrypt certificate to allow me to access my home NAS when out of the house and to share files with friends. I don’t remember how I set this up but I use Windows 10. What Command do I need to run?

Thanks

Samwisesam

My domain is: jamiescloud44.synology.me

I ran this command: sorry I don’t even know what command to run.

It produced this output: none yet

My web server is (include version): Synology NAS

The operating system my web server runs on is (include version): Windows 10

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

Synology device’s typically renew their certificates automatically. Unfortunately their UI doesn’t indicate whether this is enabled for a particular certificate. :frowning:

Did you perhaps use a website like zerossl.com or gethttpsforfree.com to obtain a certificate manually before Synology added this feature? If so, you can follow these instructions to get an automatically renewing certificate through Synology.

But if you’re pretty sure that’s what you did the first time, doing it again probably will not help you. If this is the case, please search for letsencrypt in the Synology log viewer and paste the messages that appear here.


#3

Thanks for that. I can’t access myself NAS now for a week but I’ll check out the log and get back to you
Cheers


#4

Hi, I checked the logs but nothing that jumped out at me?

cheers Jamie


#5

If there’s nothing in your logs about letsencrypt then you probably aren’t autorenewing. This could be because you did it manually before, or it could be that something is wrong with the periodic job that checks your certificates and it isn’t even running, and thus can’t log anything.

I would just click through the wizard to get a new one. If you did it manually that would be all you need to do, and if it got stuck it could even unstick it.

But keep a close eye on it in two-three months, and if it still doesn’t autorenew again we can look more closely.


#6

Ok thanks for your help. I’ll try that as an approach

Cheers

Sent from the Yahoo Mail app. Get yours!


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.