# Renew failed : 'Namespace' object error

**URL:** <https://community.letsencrypt.org/t/renew-failed-namespace-object-error/92266>\
**Category:** Help\
**Created:** [April 27, 2019, 2:06pm UTC](https://community.letsencrypt.org/t/renew-failed-namespace-object-error/92266 "2019-04-27T14:06:56Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![edrobal](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/edrobal/32/17750_2.png) [@edrobal](https://community.letsencrypt.org/u/edrobal)\
**Post date:** [April 27, 2019, 2:06pm UTC](https://community.letsencrypt.org/t/renew-failed-namespace-object-error/92266/1 "2019-04-27T14:06:56Z")

</div>

My domain is: cocktail.dyndns.biz

I ran this command:certbot renew or certbot-auto renew

It produced this output:  
/opt/eff.org/certbot/venv/lib/python2.7/site-packages/cryptography/hazmat/primitives/constant\_time.py:26: CryptographyDeprecationWarning: Support for your Python version is deprecated. The next version of cryptography will remove support. Please upgrade to a 2.7.x release that supports hmac.compare\_digest as soon as possible.  
utils.PersistentlyDeprecated2018,  
Saving debug log to /var/log/letsencrypt/letsencrypt.log

* * *

Processing /etc/letsencrypt/renewal/cocktail.dyndns.biz.conf

* * *

Renewal configuration file /etc/letsencrypt/renewal/cocktail.dyndns.biz.conf (cert: cocktail.dyndns.biz) produced an unexpected error: ‘Namespace’ object has no attribute ‘standalone\_supported\_challenges’. Skipping.

* * *

No renewals were attempted.

Additionally, the following renewal configurations were invalid:  
/etc/letsencrypt/renewal/cocktail.dyndns.biz.conf (parsefail)

* * *

0 renew failure(s), 1 parse failure(s)

My web server is (include version): none (standalone)

The operating system my web server runs on is (include version):

Linux Horus 3.12.53-40-desktop #1 SMP PREEMPT Thu Feb 25 06:26:23 UTC 2016 (b2ce64e) x86\_64 x86\_64 x86\_64 GNU/Linux

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of `certbot --version` or `certbot-auto --version` if you’re using Certbot): 0.33.1

My config is:

# renew\_before\_expiry = 30 days

version = 0.30.2  
archive\_dir = /etc/letsencrypt/archive/cocktail.dyndns.biz  
cert = /etc/letsencrypt/live/cocktail.dyndns.biz/cert.pem  
privkey = /etc/letsencrypt/live/cocktail.dyndns.biz/privkey.pem  
chain = /etc/letsencrypt/live/cocktail.dyndns.biz/chain.pem  
fullchain = /etc/letsencrypt/live/cocktail.dyndns.biz/fullchain.pem

# Options used in the renewal process

[renewalparams]  
authenticator = standalone  
account = …  
standalone\_supported\_challenges = tls-sni-01  
post\_hook = /usr/bin/tomcat-renew  
server = [https://acme-v02.api.letsencrypt.org/directory](https://acme-v02.api.letsencrypt.org/directory)

---

<div class="post-metadata">

**Author:** ![JuergenAuer](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/juergenauer/32/26491_2.png) [@JuergenAuer](https://community.letsencrypt.org/u/JuergenAuer)\
**Post date:** [April 27, 2019, 2:16pm UTC](https://community.letsencrypt.org/t/renew-failed-namespace-object-error/92266/2 "2019-04-27T14:16:02Z")

</div>

Hi @edrobal

> [@edrobal](#):
>
> Renewal configuration file /etc/letsencrypt/renewal/cocktail.dyndns.biz.conf (cert: cocktail.dyndns.biz) produced an unexpected error: ‘Namespace’ object has no attribute ‘standalone\_supported\_challenges’. Skipping.

looks like you have used a very old Certbot, so the config file has too old entries.

Add a `#` to that row and try it again.

Or make a backup of that file, delete it and use

```nohighlight
certbot -d yourdomainname

```

to create a new certificate (and a new renew config file).

---

<div class="post-metadata">

**Author:** ![edrobal](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/edrobal/32/17750_2.png) [@edrobal](https://community.letsencrypt.org/u/edrobal)\
**Post date:** [April 27, 2019, 3:34pm UTC](https://community.letsencrypt.org/t/renew-failed-namespace-object-error/92266/3 "2019-04-27T15:34:07Z")

</div>

If I comment this entry and renew, I got the error: Challenge failed for domain cocktail.dyndns.biz. If I delete all file, same error +  
IMPORTANT NOTES:

- The following errors were reported by the server:

---

<div class="post-metadata">

**Author:** ![JuergenAuer](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/juergenauer/32/26491_2.png) [@JuergenAuer](https://community.letsencrypt.org/u/JuergenAuer)\
**Post date:** [April 27, 2019, 4:15pm UTC](https://community.letsencrypt.org/t/renew-failed-namespace-object-error/92266/4 "2019-04-27T16:15:57Z")

</div>

> [@edrobal](#):
>
> Detail: Invalid response from  
> [http://cocktail.dyndns.biz/.well-known/acme-challenge/sVM45sqN0CVu4NGty-G1PMKGYMH9\_jWUvq7saM6tWYw](http://cocktail.dyndns.biz/.well-known/acme-challenge/sVM45sqN0CVu4NGty-G1PMKGYMH9_jWUvq7saM6tWYw)

Your configuration doesn't work.

Checking your config some things are looking ok ( [https://check-your-website.server-daten.de/?q=cocktail.dyndns.biz](https://check-your-website.server-daten.de/?q=cocktail.dyndns.biz) ):

| Domainname | Http-Status | redirect | Sec. | G |
| --- | --- | --- | --- | --- |
| • [http://cocktail.dyndns.biz/](http://cocktail.dyndns.biz/) | | | | |
| 77.56.118.228 | 302 | [http://cocktail.dyndns.biz/admin](http://cocktail.dyndns.biz/admin) | 0.087 | D |
| | | | | |
| • [http://www.cocktail.dyndns.biz/](http://www.cocktail.dyndns.biz/) | | | | |
| 77.56.118.228 | 302 | [http://www.cocktail.dyndns.biz/admin](http://www.cocktail.dyndns.biz/admin) | 0.090 | D |
| | | | | |
| • [http://cocktail.dyndns.biz/admin](http://cocktail.dyndns.biz/admin) | 301 | [http://cocktail.dyndns.biz/admin/](http://cocktail.dyndns.biz/admin/) | 0.087 | D |
| | | | | |
| • [http://cocktail.dyndns.biz/admin/](http://cocktail.dyndns.biz/admin/) | 302 | [http://cocktail.dyndns.biz/config.php](http://cocktail.dyndns.biz/config.php) | 0.100 | D |
| | | | | |
| • [http://www.cocktail.dyndns.biz/admin](http://www.cocktail.dyndns.biz/admin) | 301 | [http://www.cocktail.dyndns.biz/admin/](http://www.cocktail.dyndns.biz/admin/) | 0.093 | D |
| | | | | |
| • [http://www.cocktail.dyndns.biz/admin/](http://www.cocktail.dyndns.biz/admin/) | 302 | [http://www.cocktail.dyndns.biz/config.php](http://www.cocktail.dyndns.biz/config.php) | 0.097 | D |
| | | | | |
| • [http://cocktail.dyndns.biz/config.php](http://cocktail.dyndns.biz/config.php) | 404 | | 0.087 | M |
| Not Found | | | | |
| | | | | |
| • [http://www.cocktail.dyndns.biz/config.php](http://www.cocktail.dyndns.biz/config.php) | 404 | | 0.093 | M |
| Not Found | | | | |
| | | | | |
| • [https://cocktail.dyndns.biz/](https://cocktail.dyndns.biz/) | | | | |
| 77.56.118.228 | -2 | | 1.140 | V |
| ConnectFailure - Unable to connect to the remote server No connection could be made because the target machine actively refused it 77.56.118.228:443 | | | | |
| | | | | |
| • [https://www.cocktail.dyndns.biz/](https://www.cocktail.dyndns.biz/) | | | | |
| 77.56.118.228 | -2 | | 1.123 | V |
| ConnectFailure - Unable to connect to the remote server No connection could be made because the target machine actively refused it 77.56.118.228:443 | | | | |
| | | | | |
| • [http://cocktail.dyndns.biz/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de](http://cocktail.dyndns.biz/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de) | | | | |
| 77.56.118.228 | 404 | | 0.090 | A |
| Not Found | | | | |
| Visible Content: Not Found The requested URL /.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de was not found on this server. | | | | |
| | | | | |
| • [http://www.cocktail.dyndns.biz/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de](http://www.cocktail.dyndns.biz/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de) | | | | |
| 77.56.118.228 | 404 | | 0.083 | A |
| Not Found | | | | |

Port 80 is open, checking a not-existing file in /.well-known/acme-challenge there is the expected result http status 404 - Not found.

There answers a

> Server: Apache/2.4.6 (Sangoma) OpenSSL/1.0.2k-fips PHP/5.6.36

So find the DocumentRoot of that vHost, then use it.

```nohighlight
certbot run -a webroot certonly -w yourDocumentRoot -d cocktail.dyndns.biz

```

certonly because it looks that you have a tomcat running (your post\_hook).

---

<div class="post-metadata">

**Author:** ![edrobal](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/edrobal/32/17750_2.png) [@edrobal](https://community.letsencrypt.org/u/edrobal)\
**Post date:** [April 27, 2019, 4:32pm UTC](https://community.letsencrypt.org/t/renew-failed-namespace-object-error/92266/5 "2019-04-27T16:32:26Z")

</div>

I have no web server, only tomcat. So I use standalone but I have the “Namespace” error.

---

<div class="post-metadata">

**Author:** ![JuergenAuer](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/juergenauer/32/26491_2.png) [@JuergenAuer](https://community.letsencrypt.org/u/JuergenAuer)\
**Post date:** [April 27, 2019, 4:34pm UTC](https://community.letsencrypt.org/t/renew-failed-namespace-object-error/92266/6 "2019-04-27T16:34:24Z")

</div>

> [@edrobal](#):
>
> I have no web server

You see: There answers a webserver.

[http://cocktail.dyndns.biz/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de](http://cocktail.dyndns.biz/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de)

So you have one running webserver, so use that.

---

<div class="post-metadata">

**Author:** ![edrobal](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/edrobal/32/17750_2.png) [@edrobal](https://community.letsencrypt.org/u/edrobal)\
**Post date:** [April 27, 2019, 4:50pm UTC](https://community.letsencrypt.org/t/renew-failed-namespace-object-error/92266/7 "2019-04-27T16:50:44Z")

</div>

It is the pbx web server. It is always running and there was no problem before.

---

<div class="post-metadata">

**Author:** ![JuergenAuer](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/juergenauer/32/26491_2.png) [@JuergenAuer](https://community.letsencrypt.org/u/JuergenAuer)\
**Post date:** [April 27, 2019, 5:07pm UTC](https://community.letsencrypt.org/t/renew-failed-namespace-object-error/92266/8 "2019-04-27T17:07:48Z")

</div>

> [@edrobal](#):
>
> It is always running and there was no problem before.

You have an old config file. So you may have used tls-sni-01 validation via port 443. That's not longer supported.

So you have

- to switch to http-01 validation, then port 80 is required. That can't work if port 80 is blocked by another instance. Or you have to stop that instance and use standalone (or)
- switch to another validation method: dns-01 or tls-alpn-01 (via port 443, but Certbot doesn't support that).

Check

> **[Challenge Types - Let's Encrypt](https://letsencrypt.org/docs/challenge-types/)**
>
> When you get a certificate from Let’s Encrypt, our servers validate that you control the domain names in that certificate using “challenges,” as defined by the ACME standard. Most of the time, this validation is handled automatically by your ACME...

---

<div class="post-metadata">

**Author:** ![edrobal](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/edrobal/32/17750_2.png) [@edrobal](https://community.letsencrypt.org/u/edrobal)\
**Post date:** [April 27, 2019, 5:53pm UTC](https://community.letsencrypt.org/t/renew-failed-namespace-object-error/92266/9 "2019-04-27T17:53:29Z")

</div>

OK. I changed my pbx port and all is working… until next 💣

Thank you very much

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/letsencrypt/original/3X/c/a/ca6c06ea1ea201324bba7048c6841ce60236468d.png) [@system](https://community.letsencrypt.org/u/system)\
**Post date:** [May 27, 2019, 5:53pm UTC](https://community.letsencrypt.org/t/renew-failed-namespace-object-error/92266/10 "2019-05-27T17:53:35Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
