Renew Error on nextcloud server

Hi guys,

i tried to renew my cert, but i ran always in an error:

Attempting to renew cert (nextcloud.okr-evang.at) from /etc/letsencrypt/renewal/nextcloud.okr-evang.at.conf produced an unexpected error: The manual plugin is not working; there may be problems with your existing configuration.
The error was: PluginError(‘An authentication script must be provided with --manual-auth-hook when using the manual plugin non-interactively.’,). Skipping.
All renewal attempts failed. The following certs could not be renewed:

  • /etc/letsencrypt/live/nextcloud.okr-evang.at/fullchain.pem (failure)*
    1 renew failure(s), 0 parse failure(s)

I ran this command:
sudo certbot renew --dry-run

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is 0.28

i searched trought the forum, but every solution i found didn’t work for me.

i hope someone can help mit to get back on track

thx

If you used --manual to create your certificate (without any automation hooks), you can’t use the renew command.

You have to use the same --manual process you used the first time.

2 Likes

thx, can you write me the command, i installed the complete serve with a provided script.

If you used a script, then you’d have to refer to the script.

You might have used:

certbot certonly -a manual --preferred-challenges dns -d nextcloud.okr-evang.at

but I have no way to know.

1 Like

now i get that error

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator manual, Installer None
Cert is due for renewal, auto-renewing…
Renewing an existing certificate
Performing the following challenges:
dns-01 challenge for nextcloud.okr-evang.at


NOTE: The IP of this machine will be publicly logged as having requested this
certificate. If you’re running certbot in manual mode on a machine that is not
your server, please ensure you’re okay with that.

Are you OK with your IP being logged?


(Y)es/(N)o: Cleaning up challenges
An unexpected error occurred:
EOFError
Please see the logfiles in /var/log/letsencrypt for more details.

in the Log file ist only the entry
EOFError

2019-03-07 11:23:22,111:DEBUG:certbot.error_handler:Calling registered functions
2019-03-07 11:23:22,111:INFO:certbot.auth_handler:Cleaning up challenges
2019-03-07 11:23:22,111:DEBUG:certbot.log:Exiting abnormally:
Traceback (most recent call last):
File “/usr/bin/certbot”, line 11, in
load_entry_point(‘certbot==0.28.0’, ‘console_scripts’, ‘certbot’)()
File “/usr/lib/python3/dist-packages/certbot/main.py”, line 1340, in main
return config.func(config, plugins)
File “/usr/lib/python3/dist-packages/certbot/main.py”, line 1225, in certonly
lineage = _get_and_save_cert(le_client, config, domains, certname, lineage)
File “/usr/lib/python3/dist-packages/certbot/main.py”, line 116, in _get_and_save_cert
renewal.renew_cert(config, domains, le_client, lineage)
File “/usr/lib/python3/dist-packages/certbot/renewal.py”, line 305, in renew_cert
new_cert, new_chain, new_key, _ = le_client.obtain_certificate(domains, new_key)
File “/usr/lib/python3/dist-packages/certbot/client.py”, line 335, in obtain_certificate
orderr = self._get_order_and_authorizations(csr.data, self.config.allow_subset_of_names)
File “/usr/lib/python3/dist-packages/certbot/client.py”, line 371, in _get_order_and_authorizations
authzr = self.auth_handler.handle_authorizations(orderr, best_effort)
File “/usr/lib/python3/dist-packages/certbot/auth_handler.py”, line 75, in handle_authorizations
resp = self._solve_challenges(aauthzrs)
File “/usr/lib/python3/dist-packages/certbot/auth_handler.py”, line 132, in _solve_challenges
resp = self.auth.perform(all_achalls)
File “/usr/lib/python3/dist-packages/certbot/plugins/manual.py”, line 155, in perform
self._verify_ip_logging_ok()
File “/usr/lib/python3/dist-packages/certbot/plugins/manual.py”, line 182, in _verify_ip_logging_ok
if display.yesno(msg, cli_flag=cli_flag, force_interactive=True):
File “/usr/lib/python3/dist-packages/certbot/display/util.py”, line 218, in yesno
no=_parens_around_char(no_label)))
File “/usr/lib/python3/dist-packages/certbot/display/util.py”, line 85, in input_with_timeout
raise EOFError
EOFError
2019-03-07 11:23:22,117:ERROR:certbot.log:An unexpected error occurred

It seems that you are not responding to the questions Certbot is asking you, e.g.

Are you OK with your IP being logged?
(Y)es/(N)o:

or there is some problem with your terminal where your response is not being detected.

1 Like

i saw it, i didn’t realise that i can’t do it over the webadmin console thx for help

1 Like

problem solved - thx @_az

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.