Renew cmd fails: max() arg is an empty sequence. Skipping


#1

I setup a cert to cover my domain and a few subdomains. When I try to renew with letsencrypt renew, I get the error:

2016-12-23 06:14:11,962:WARNING:letsencrypt.cli:Attempting to renew cert from /etc/letsencrypt/renewal/EXAMPLE.com.conf produced an unexpected error: max() arg is an empty sequence. Skipping.

it looks like latest_common_version() is being called with an empty list of versions. Not sure what that means.

I’m running letsencrypt 0.4.1. Error details in this pastebin: http://pastebin.com/7xwXbdtc


#2

To me, this sounds like a bug which was fixed ages ago… Is there a posibillity you could upgrade your letsencrypt? I.e., to certbot, which is the same client, but renamed and which is updated (letsencrypt is not).


#3

I am indeed on Ubuntu 16.04. I upgraded / switched to certbot from the git repo and I still get the same error (though now from certbot, of course). http://pastebin.com/pMdbJhHB

Is there any harm in me just creating new certs in case the problem was in letsencrypt 0.4.1’s creation of the metadata? Do I first need to revoke those certs? They’re currently only used on my web server for a few low-volume services.


#4

No.

No.   


#5

Thanks. I deleted my /etc/letsencrypt dir and recreated the certs and now it’s all good. Thanks!


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.