# Renew cert Max retries exceeded with url: /directory

**URL:** <https://community.letsencrypt.org/t/renew-cert-max-retries-exceeded-with-url-directory/152265>\
**Category:** Help\
**Created:** [May 22, 2021, 6:54pm UTC](https://community.letsencrypt.org/t/renew-cert-max-retries-exceeded-with-url-directory/152265 "2021-05-22T18:54:16Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![plimsoftware](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/plimsoftware/32/49860_2.png) [@plimsoftware](https://community.letsencrypt.org/u/plimsoftware)\
**Post date:** [May 22, 2021, 6:54pm UTC](https://community.letsencrypt.org/t/renew-cert-max-retries-exceeded-with-url-directory/152265/1 "2021-05-22T18:54:16Z")

</div>

My domain is: **plimsoftware.pt**

I ran this command: **sudo certbot renew**

It produced this output:

> Processing /etc/letsencrypt/renewal/www.plimsoftware.pt.conf
> 
> * * *
> 
> Cert is due for renewal, auto-renewing...  
> Plugins selected: Authenticator standalone, Installer None  
> Attempting to renew cert (www.plimsoftware.pt) from /etc/letsencrypt/renewal/www.plimsoftware.pt.conf produced an unexpected error: HTTPSConnectionPool(host='[acme-v02.api.letsencrypt.org](http://acme-v02.api.letsencrypt.org)', port=443): Max retries exceeded with url: /directory (Caused by NewConnectionError('\<urllib3.connection.VerifiedHTTPSConnection object at 0x7f3e1216b2b0\>: Failed to establish a new connection: [Errno -3] Temporary failure in name resolution',)). Skipping.

My web server is (include version): **nginx/1.14.0 (Ubuntu)**

The operating system my web server runs on is (include version): **Ubuntu 18.04.4 LTS**

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): **yes**

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): **no**

The version of my client is (e.g. output of `certbot --version` or `certbot-auto --version` if you're using Certbot): **certbot 0.27.0**

Anybody can help? Thanks!

---

<div class="post-metadata">

**Author:** ![Osiris](https://avatars.discourse-cdn.com/v4/letter/o/839c29/32.png) [@Osiris](https://community.letsencrypt.org/u/Osiris)\
**Post date:** [May 22, 2021, 6:59pm UTC](https://community.letsencrypt.org/t/renew-cert-max-retries-exceeded-with-url-directory/152265/2 "2021-05-22T18:59:06Z")

</div>

> [@plimsoftware](#):
>
> Temporary failure in name resolution

This suggests to me that the DNS resolving capabilities on your server are broken. Can you test that by running `host acme-v02.api.letsencrypt.org` please?

---

<div class="post-metadata">

**Author:** ![plimsoftware](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/plimsoftware/32/49860_2.png) [@plimsoftware](https://community.letsencrypt.org/u/plimsoftware)\
**Post date:** [May 22, 2021, 11:01pm UTC](https://community.letsencrypt.org/t/renew-cert-max-retries-exceeded-with-url-directory/152265/3 "2021-05-22T23:01:45Z")

</div>

I have my site in a VM on Google Cloud Platform. Running `host acme-v02.api.letsencrypt.org` i have the following: `;; connection timed out; no servers could be reached`.

Same result with `host google.com`

---

<div class="post-metadata">

**Author:** ![Osiris](https://avatars.discourse-cdn.com/v4/letter/o/839c29/32.png) [@Osiris](https://community.letsencrypt.org/u/Osiris)\
**Post date:** [May 23, 2021, 7:40am UTC](https://community.letsencrypt.org/t/renew-cert-max-retries-exceeded-with-url-directory/152265/4 "2021-05-23T07:40:10Z")

</div>

That means your VMs DNS resolving doesn't work in general and it's is not related to Let's Encrypt.

---

<div class="post-metadata">

**Author:** ![plimsoftware](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/plimsoftware/32/49860_2.png) [@plimsoftware](https://community.letsencrypt.org/u/plimsoftware)\
**Post date:** [May 23, 2021, 3:54pm UTC](https://community.letsencrypt.org/t/renew-cert-max-retries-exceeded-with-url-directory/152265/5 "2021-05-23T15:54:31Z")

</div>

I resolved doing

> sudo systemctl restart systemd-resolved.service

😀 😀

---

<div class="post-metadata">

**Author:** ![webprofusion](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/webprofusion/32/85310_2.png) [@webprofusion](https://community.letsencrypt.org/u/webprofusion)\
**Post date:** [May 24, 2021, 2:24am UTC](https://community.letsencrypt.org/t/renew-cert-max-retries-exceeded-with-url-directory/152265/6 "2021-05-24T02:24:34Z")

</div>

I'd recommend checking `sudo apt-get update` to see if there are some updates to install as `systemd-resolved` should be pretty hard to crash, normally.

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/letsencrypt/original/3X/c/a/ca6c06ea1ea201324bba7048c6841ce60236468d.png) [@system](https://community.letsencrypt.org/u/system)\
**Post date:** [June 23, 2021, 2:25am UTC](https://community.letsencrypt.org/t/renew-cert-max-retries-exceeded-with-url-directory/152265/7 "2021-06-23T02:25:35Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
