Redirected too many times issue after installing letsencrypt


#1

Hi all,

i am using a virtual host to point a domain to a specific folder after installing letencrypt I am facing an issue with redirection. I am using prestashop for this website

this host configuration file : lpfiles.com.conf

<VirtualHost *:80>
# The ServerName directive sets the request scheme, hostname and port that
# the server uses to identify itself. This is used when creating
# redirection URLs. In the context of virtual hosts, the ServerName
# specifies what hostname must appear in the request’s Host: header to
# match this virtual host. For the default virtual host (this file) this
# value is not decisive as it is used as a last resort host regardless.
# However, you must set it for any further virtual host explicitly.
#ServerName www.example.com
ServerAdmin admin@hyderabadbazar.com
ServerName hyderabadbazar.com
ServerAlias www.hyderabadbazar.com
DocumentRoot /var/www/html/lpfiles

<Directory /var/www/html/lpfiles>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Order allow,deny
            allow from all
</Directory>


ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

# For most configuration files from conf-available/, which are
# enabled or disabled at a global level, it is possible to
# include a line for only one particular virtual host. For example the
# following line enables the CGI configuration for this host only
# after it has been globally disabled with "a2disconf".
#Include conf-available/serve-cgi-bin.conf

RewriteEngine on
RewriteCond %{SERVER_NAME} =hyderabadbazar.com [OR]
RewriteCond %{SERVER_NAME} =www.hyderabadbazar.com
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

vim: syntax=apache ts=4 sw=4 sts=4 sr noet

but if i remove
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
my site is working fine but https is appearing.

can some one please help me out


#2

Please show the configuration for <VirtualHost *:443>
The above configuration is responsible for http only, so does not influence anything after the first redirect.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.