Python Error on Certificate Renewal


#1

Hello Everyone,

Firstly, thank you for providing an excellent service of free SSL certificates with great documentation.

My certificates are due to expire in 12 days so I tried renewing them post which I’d have proceeded towards automating the same via cron.

However, I’m facing an issue with certificate renewal when I run the certbot utility, details of which are given below.

My domain is: vinayhegde.info / www.vinayhegde.info

I ran this command || It produced this output:Code

My web server is (include version): nginx version: nginx/1.12.2

The operating system my web server runs on is (include version): CentOS Linux release 7.4.1708 (Core)

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

Kindly let me know if the provided information is insufficient or anything else would be required from my side to resolve this at the earliest which might assist fellow users in case anyone has the same problem.

Thanks in advance,
Vinay


#2

I guess installing python-configobj would make the error go away, but it’s strange it isn’t a dependency which is automatically installed…


#3

@Osiris. strange indeed! Thanks for pointing out the direction, though.

I proceeded to install the configobj via Pip which led to some more broken dependencies. Have fixed them here

Mostly, the above process will land us on this error
the ImportError: 'pyOpenSSL' module missing required functionality. Try upgrading to v0.14 or newer.

A quick search via Google will provide you info that this issue has been faced by multiple users, more info on Github

Now as per the above link, A user dvershinin has very correctly mentioned that pip & yum packages shouldn’t be confused with each other. However, I tried what he’s mentioned and somehow I broke more than I fixed, with an error :sweat_smile:

Those can be fixed by upgrading certain packages via Pip using sudo pip install <package> --upgrade where would be requests, six, urllib3 which we previously re-installed, and you’ll end up back on the pyOpenSSL error.

To fix the pyOpenSSL error, follow the steps mentioned by kevinbaluha on the same github issue which will most likely fix it.

Refer - http://clipboard.space/clip/p0LadpqB52FnrXe2GGny

Hope this helps everyone, cheers!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.