Problems with renewing certificate

I tried to renew SSL Certificate on my website. It was automatic but now I am getting this error when i try to renew it:

Error: Could not issue a Let’s Encrypt SSL/TLS certificate for E-KUCENI.LV . Authorization for the domain failed.

Invalid response from
Type: urn:ietf:params:acme:error:connection
Status: 400
Detail: Fetching http://www.E-KUCENI.LV/.well-known/acme-challenge/s45an6wi2ppinDO2YUX5vhav9pb-wXJ9m9Xpjaah9pQ: Invalid hostname in redirect target, must end in IANA registered TLD

Im guessing it is because of uppercase domain( Fetching http://www.E-KUCENI.LV/…) but i have no idea why is that and how to fix it. I don’t have great insight about this so any help would be appreciated.

My domain is:

I ran this command: Didn’t run any command

It produced this output:-

My web server is (include version):Plesk Onyx Version 17.8.11

The operating system my web server runs on is (include version):‪Ubuntu 18.04.2 LTS‬

My hosting provider, if applicable, is: Contabo

I can login to a root shell on my machine (yes or no, or I don’t know):I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):Using Plesk 12.0

That's right. This issue should be fixed either today or tomorrow (depending on timezone) I believe, once va: case-insensitivity of suffixes in http redirs by alexzorin · Pull Request #4218 · letsencrypt/boulder · GitHub is deployed to production.

As for why it's happening ... only you can really know this. Look around in Plesk for website redirects?

If you have SSH access, you can try grep around in your home directory:

\grep -R "E-KUCENI.LV" ~username/

Okay, I see. Thanks for your answer!

1 Like

Thanks @_az!

@tempus77 I expect the fix will be deployed in the next 4-5 hours. You can follow to watch for the production Boulder update.

Hi again @tempus77,

The bug fix that @_az referenced has been deployed to production. You should now be able to renew this certificate again without error.

Sorry for the inconvenience!

Yes, everything is working now! Thanks!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.