Problems setting up Certbot on Ubuntu Server 20.04 with Apache

My domain is:
I ran this command: certbot --apache
certbot certonly --webroot -w /var/www -d -d -d
It produced this output:
I apparently reached my attempt limit as I got the "There were too many requests of a given type" error. So I can't give the output from the ssh command line at the moment. But it's the basic same error as what 'Let's Debug' is telling me:


ERROR has an A (IPv4) record ( but a request to this address over port 80 did not succeed. Your web server must have at least one working IPv4 or IPv6 address.

A timeout was experienced while communicating with Get "": context deadline exceeded

@0ms: Making a request to (using initial IP
@0ms: Dialing
@10001ms: Experienced error: context deadline exceeded

My web server is (include version): Apache (latest version)
The operating system my web server runs on is (include version): Ubuntu Server 20.04 LTS
My hosting provider, if applicable, is: netfirms
I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No. I am using netfirms only for DNS entry. The DNS entries setup in the netfirms control panel are:
A dev (my ip)
A www (my ip)
A * (my ip)
A @ (my ip)

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0

And finally my /etc/hosts file: localhost poillion

I don't understand what I'm doing wrong. Let's Debug and the cli tell me they're getting a timeout. But it seems to be resolving just fine within my LAN. I know that's not helpful, but I don't know why it's not accessible from the internet. I have port forwarding setup on my router as well. I connect via ssh from external networks to the server all the time. Anyone have any ideas on what to check?

Thank you!

1 Like

Welcome @lorewap3

ssh works usually on port 22 so not the same as port 80 (http) or port 443 (https)

Port 443 for https is open but connections fail.

Port 80 is not visible or working at all. Sometimes home ISPs block port 80 so maybe check with them. Otherwise, make sure port 80 is open on your router and you forward it if/as needed.


Ah that was it. My ISP is blocking incoming port 80. You hit it right on the money. Thanks Mike!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.