Probleme de creation certificats via plesk


#1

Veuillez remplir les champs ci-dessous pour que nous puissions vous aider. Remarque : vous devez fournir votre nom de domaine pour obtenir de l’aide. Les noms de domaine des certificats émis sont tous rendus publics dans les journaux de Transparence de Certificat (par exemple, https://crt.sh/?q=example.com). Par conséquent, le fait de ne pas indiquer votre nom de domaine ici n’aide pas à le garder secret, mais rend plus difficile pour nous le fait de vous aider.

Je peux lire des réponses en Anglais : Oui avec dificulté

Mon nom de domaine est : jrccolors.com

J’ai exécuté cette commande : Hier via Plesk

Elle a produit cette sortie : certificats créé mais pas valide

Mon serveur Web est (inclure la version) : Debia 8 plesk

Le système d’exploitation sur lequel mon serveur Web s’exécute est (version incluse) : Débian 8

Mon hébergeur, le cas échéant, est : OVH

Je peux me connecter à un shell root sur ma machine (oui ou non, ou je ne sais pas) : oui

J’utilise un panneau de configuration pour gérer mon site (non, ou fournit le nom et la version du panneau de configuration) : Oui Plesk

J’ai installer plesk sur un nouveau serveur hier et je pense avoir fait la demande de certificat trop tot et donc cela fait que j’ai cette erreur

Aucun des noms communs du certificat ne correspond au nom saisi (www.jrccolors.com). Vous pouvez recevoir une erreur lorsque vous accédez à ce site dans un navigateur Web.

merci de votre aide d’avance.

Jérémy


#2

Plesk a bien crée des certificats valides (visible ici: https://crt.sh/?q=%jrccolors.com)

Le problème est qu’il ne les utilise pas.

Avez-vous bien effectué les dernières étapes du tutoriel ? https://docs.plesk.com/fr-FR/onyx/reseller-guide/gérer-des-sites-web/sites-web-et-domaines/avancé-sécurité-du-site-web/protéger-les-connexions-avec-des-certificats-ssltls/obtenir-un-certificat-ssltls-gratuit-de-lets-encrypt.77233/

Une fois le certificat installé, vous pouvez l’utiliser pour protéger votre site :

  1. Allez sous Sites Web & Domaines et cliquez sur Paramètres d’hébergement .
  2. Cochez la case Prise en charge SSL/TLS .
  3. Sélectionnez le certificat Let’s Encrypt que vous venez de recevoir dans le menu Certificat et cliquez sur OK .

#3

Merci de votre réponse et de prendre le temps de m’aider.

est-ce bien cela ? si oui c’est fait depuis hier.

Aurais-je oublier autre chose…

Pour info j’ai transféré le domaine d’un register et aussi de serveur.
J’ai fait la demande de certificats avant le transfert définitif .

Serait-ce cela le problème.?


#4

Possible que les certificats aient été généré sur l’ancien serveur, mais ils ne devraient pas apparaitre ici…

ATTENTION: il y a une limite de création de 5 certificats identiques sur 7 jours glissant, vous risquez de l’atteindre!

Peut-être qu’un simple redémarrage du serveur web suffirait ?


#5

J’essaye le redémarrage et vous dis cela .


#6

Suite au redémarrage cela ne change rien

Ce que je ne comprends pas c’est ceci

Aucun des noms communs du certificat ne correspond au nom saisi (www.jrccolors.com). Vous pouvez recevoir une erreur lorsque vous accédez à ce site dans un navigateur Web. En savoir plus sur les erreurs d’incompatibilité de nom .

https://www.sslshopper.com/ssl-checker.html#hostname=www.jrccolors.com

je suis perdu .


#7

Question bête, vous êtes sur de modifier les paramètres de l’interface Plesk du nouveau serveur (92.222.172.44) ? Et que votre DNS pointe bien vers celui-ci ?


#8

L’interface DNS est géré par OVH

mais je ne comprends pas ce que veut dire ceci
“Aucun des noms communs du certificat ne correspond au nom saisi”


#9

Le serveur web présente un certificat auto-signé, qui n’est pas valide.

Je ne comprend pas pourquoi il ne présente pas le certificat valide qu’il a généré avec Let’s Encrypt…


#10

En tout cas je te remercie de ton aide.

je ne comprends pas non plus.

peut on le révoquer et recommencer a zéro ? quite pour moi a tout reinstaller ?

je sais pas quoi faire, sinon je désactive et le SSL pendant quelques jours et le reactive ?

:sob: :cry:

j’ai 2 serveurs et une dizaine de domaine c’est la première fois qu’il me fait ce problème.


#11
  • Révoquer est inutile (car ce n’est pas un cas de perte de clé privé)
  • Recommencer à zéro est une piste, mais pas tout de suite: Il y a une limite de 5 certificats identiques pour 7 jours et vous en avez crée 4 (même s’ils ne sont pas utilisés) entre le 29 et 30 janvier, donc il est plus prudent d’attendre 7 jours pour faire des tests supplémentaires…

https://crt.sh/?q=jrccolors.com est utile pour voir les certificats réellement créés (ils peuvent mettre un certains temps à apparaitre), attention: ils apparaissent en double (pour une histoire de pre-certificates).

Ping @juergenauer @rg305 Help, I’m out of idea and solutions…


#12

Hi @djedje

you have created new certificates - yesterday and today:

https://crt.sh/?q=jrccolors.com

But you don’t use one of these, instead you use a self signed certificate

E=info@plesk.com, CN=Plesk, O=Plesk, L=Schaffhausen, C=CH 
	11.11.2018
	11.11.2019

I don’t use Plesk, but if I know it correct you must have an option to select this certificate (instead of the self signed certificate).


#13

Apparently there is an option to select it, and he did select it:

(The “Certificat” select in the bottom of the image)


#14

But then it looks like a Plesk problem.

So first I would “play”. Select explicit a self signed, save it, check it, then back. Remove SSL, then add it again etc.

Or asking in the Plesk forum.

Plesk is a closed world, like cPanel. If the menus don’t do what they say, it’s a problem.


#15

Traduction:

Mais alors cela ressemble à un problème de Plesk.

Alors je commencerais par «jouer». Sélectionnez explicitement le certificat self-signed, sauvegardez, vérifiez, puis revenez. Supprimez SSL, puis ajoutez-le à nouveau, etc.

Ou demandez sur le forum de Plesk.

Plesk est un monde fermé, comme cPanel. Si les menus ne font pas ce qu’ils disent, c’est un problème.


#16

Hello tout le monde
Merci a vous de m’avoir aidé
la solution a été de refaire le serveur

je pense comme disait JuergenAuer le pb venais du serveur plesk

J’ai voulu aller trop vite et j’ai activé un ssl avant que le serveur soit fini et ça a merdé.
Il faut savoir être patient :slight_smile:
Merci encore de votre aide.