Problem with wp encrypt

it’s a new site and i trid to install let’s encrypt with wp encryption plugin in wordpress.
It couldn’t generate the ssl
Yesterday it worked fine with another wordpress site.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain

I ran this command:aplly let’s encrypt through wp encrypt plugin in wordpress

It produced this output:ERROR: CREATE_ORDER:RuntimeException: Error creating new order :: Cannot issue for “”: Domain name contains an invalid character in /var/www/vhosts/
Stack trace:
#0 /var/www/vhosts/ WPLEClient\WPLEConnector->request(‘POST’, ‘https://acme-v0…’, ‘{“protected”:"e…’)
#1 /var/www/vhosts/ WPLEClient\WPLEConnector->post(‘https://acme-v0…’, ‘{“protected”:"e…’)
#2 /var/www/vhosts/ WPLEClient\LEOrder->createOrder(Array, ‘’, ‘’)
#3 /var/www/vhosts/ WPLEClient\LEOrder->__construct(Object(WPLEClient\WPLEConnector), 1, Array, ‘…’, Array, ‘rsa-4096’, ‘’, ‘’)
#4 /var/www/vhosts/ WPLEClient\WPLEClient->getOrCreateOrder(‘…’, Array)
#5 /var/www/vhosts/ WPLE_Core->wple_generate_order()
#6 /var/www/vhosts/ WPLE_Core->wple_generate_verify_ssl()
#7 /var/www/vhosts/ WPLE_Core->__construct(Array)
#8 /var/www/vhosts/ WPLE_Admin->wple_save_email_generate_certs(’’)
#9 /var/www/vhosts/ WP_Hook->apply_filters(NULL, Array)
#10 /var/www/vhosts/ WP_Hook->do_action(Array)
#11 /var/www/vhosts/ do_action(‘admin_init’)
#12 {main}

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable,

I can login to a root shell on my machine (yes or no, or I don’t know):no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):plesk onyx

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

what does this interface look like, what did you type in its settings?


Security is an important subject regarding SSL/TLS certificates, of course. It is obvious that your private key, stored on your web server, should never be accessible from the web. When the plugin created the keys directory for the first time, it will store a .htaccess file in this directory, denying all visitors. Always make sure yourself your keys aren’t accessible from the web! We are in no way responsible if your private keys go public. If this does happen, the easiest solution is to check folder permissions on your server and make sure public access is forbidden for root folders. Next, create a new certificate.


The only thing standing between a TLS key and its public download is a .htaccess that may even be disabled and only works for apache?

Change client if you can.

it’s e very simple plugin you register and it generates three file for the ssl,you download them and you install them in the plesk panel in the ssl section.

Show me, please. Take screenshots.

it’s just this no other settings

I think it’s a bug in the plugin. click on the ? near the url on top. What does it say?

Hi @serpico

you can create a certificate with as domain name. Or +

You can’t create a certificate with a subfolder

1 Like

it says "add a cname with name www pointing to your non-www domain
but this is already done
I’ve checked

the problem is that is adds /wordpress after. you need to understand why.

but my advice is to drop this plugin and use another acme client

1 Like

the domain was but it was put there by itself I wasn;t asked for the domain

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.