Problem with obtaining SSL certificate/ ERR_CERT_COMMON_NAME_INVALID Inbox x


#1

Hello all,

I am trying to get SSL certificate for my website crepemerinos.com by securing Nginx on Ubuntu 16.04. I am using these steps to obtain the certificate : [https://www.digitalocean.com/community/tutorials/how-to-secure-nginx-with-let-s-encrypt-on-ubuntu-16-04]

I’m facing a problem in this step:

During the configuration of HTTPS settings, it asks for two options:-

  1. Easy - Allow both HTTP and HTTPS access to these sites
  2. Secure - Make all requests redirect to secure HTTPS access

First time, I tried to opt 2nd option thus redirecting all requests to HTTPS, but I see this screen with ERR_CERT_COMMON_NAME_INVALID error while opening https://crepemerinos/wp-admin

I tried to use the 1st option, in which case, the site works with http but if it is opened with https:// it does something else as shown.

if i open the admin panel using https:// it shows the same error page ERR_CERT_COMMON_NAME_INVALID

Could you help me figuring out what the problem could be?

I have another website for which I obtained the certificate using the same instructions but 5 months ago, and it works perfectly and I am not having any problem.

Hoping to get this problem resolved.

Thanks
​Vineet​


#2

You need to look into your configuration and find out why nginx or Wordpress is redirecting crepemerinos.com to the generic hostname that EC2 instances have. You might need to change your system hostname, your webroot settings, or change nginx/Wordpress from using the system hostname to your personal one. It might be a leftover rule from before you got your real domain.


#3

Sorry, I didn’t understand it. Could you explain in more detail or if you could suggest certain guideline to follow? That might help me more as I’m a beginner.


#4

You issued a certificate for crepemerinos.com, but if you look in your browser window, you’re navigating to ec2-52-29-182-255.eu-central1.compute.amazonaws.com. We don’t have enough information about your setup to determine why you’re being redirected here, but that’s what’s happening. Since this isn’t your domain that you issued a certificate for, you’re going to see security warnings.


#5

Thanks for pointing that out Jared.
Indeed, it seems like this could be a problem.
Any idea why this might be redirecting to ec2-52-29-182-255.eu-central1.
compute.amazonaws.com? I had used the same method of certification on
another site and it worked fine.

But I can’t figure out why this might be redirecting… Has it happened to
anyone else before?


#6

There could be several things doing that, but most likely it’s your web server configs, or a weird DNS configuration.


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.