Problem when creating certificate

I was trying to create the certificate (from my AWS) by doing following:

form my opt/letsencrypt I run

.letsencrypt-auto certonly --standalone --debug

When I was prompt to enter the domain name i messed up my IP entries somehow and had to exit so I didnt know how to get back to that prompt so I run again command below.

.letsencrypt-auto certonly --standalone --debug

and I was prompt to enter domain name which I did and I received this:

Please enter in your domain name(s) (comma and/or space separated) (Enter 'c’
to cancel): xx.xxx.xxx.xxx.xip.io
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for xx.xxx.xxx.xxx.xip.io
Waiting for verification…
Cleaning up challenges
Exiting abnormally:
Traceback (most recent call last):
** File “/opt/eff.org/certbot/venv/bin/letsencrypt”, line 11, in **
** sys.exit(main())**
** File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/main.py”, line 1240, in main**
** return config.func(config, plugins)**
** File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/main.py”, line 1120, in certonly**
_** lineage = get_and_save_cert(le_client, config, domains, certname, lineage)**
_** File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/main.py”, line 118, in get_and_save_cert**
** lineage = le_client.obtain_and_enroll_certificate(domains, certname)**
** File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/client.py”, line 357, in obtain_and_enroll_certificate**
** certr, chain, key, _ = self.obtain_certificate(domains)**
** File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/client.py”, line 336, in obtain_certificate**
** domains, csr, authzr=authzr)**
** File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/client.py”, line 278, in obtain_certificate_from_csr**
** authzr)**
** File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/acme/client.py”, line 314, in request_issuance**
** headers={‘Accept’: content_type})**
** File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/acme/client.py”, line 709, in post**
_** return self.post_once(*args, kwargs)
_** File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/acme/client.py”, line 722, in post_once**
_** return self.check_response(response, content_type=content_type)**
_** File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/acme/client.py”, line 583, in check_response**
** raise messages.Error.from_json(jobj)**
Error: urn:acme:error:rateLimited :: There were too many requests of a given type :: Error creating new cert :: too many certificates already issued for: xip.io: see https://letsencrypt.org/docs/rate-limits/
Please see the logfiles in /var/log/letsencrypt for more details.

Can anyone suggest/help how to get this certificate at this point please.

do I have to wait to re-try this and if so how long?

Thanks

Edit: The rate limits have been increased since this post was written.


Well… The limit is probably 20 certificates per week for the domain.

As you can see, people issue a lot of certificates:

https://crt.sh/?Identity=%.xip.io&iCAID=16418

You can run the numbers yourself, or use a tool like lectl to calculate when it will next be possible to issue a new certificate. But that moment will probably change as people renew certificates, or if someone else issues a new certificate at just the right time.

(Renewing is possible regardless of that rate limit, but will still count against the rate limit and prevent the creation of new certificates.)

You should probably register your own domain. :sweat:

1 Like

I dont have my own domain. what do you suggest i do now please?
Is the error I am receiving error caused by rate limit?

It's obvious, isn't it? Get your own domain. It doesn't even have to cost anything; you can get free domains at freenom.com.

I have this set it amazon cloud and dont have my own domain as of now.

From this table https://crt.sh/?identity=%25.xip.io&iCAID=16418&p=1&n=100 when could I try to run this command again?

I got the domain name so do I have to reverse the steps I already took until I received this error?

Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.