Problem renewing certificate - permission denied


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: recordingology.com

I ran this command: Tried issuing cert in Cpanel

It produced this output: There was a problem processing your request

Error issuing certificate
Failed to issue certificate
Unable to create file (/home/recordin/public_html/.well-known/acme-challenge/gCVaMknHCGhO-bBVGaFeLlHPn4Qkn9wN66KlD-vNJ1U) in your web directory: open /home/recordin/public_html/.well-known/acme-challenge/gCVaMknHCGhO-bBVGaFeLlHPn4Qkn9wN66KlD-vNJ1U: permission denied

My web server is (include version):

The operating system my web server runs on is (include version): CENTOS 6.9 xen pv

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Cpanel v68.0.38


#2

Hi @atracksler,

Did you install cPanel yourself, or did a hosting provider set it up for you as part of a shared hosting plan?


#3

Hi Adam,

I recognize that error message from our FleetSSL plugin.

You’ll need to ensure that the directories descending to the acme-challenge directory are owned by the recordin user, because the issuance process runs as the non-privileged user.

This error most likely occurs when directories or files have been created as root.

You can find where the permissions have gone wrong by running:

namei -l /home/recordin/public_html/.well-known/acme-challenge/

If you need further help, please email us.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.