Problem creating a certificate for a new domain in a Ubuntu Server

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot --nginx -d -d

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
http-01 challenge for
Waiting for verification...
Challenge failed for domain
Challenge failed for domain
http-01 challenge for
http-01 challenge for
Cleaning up challenges
Some challenges have failed.


My web server is (include version): Linux Ubuntu 20.04 - Nginx 1.18

The operating system my web server runs on is (include version): Ubuntu 20.04

My hosting provider, if applicable, is: Myself

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0

I tried the same configuration in another server and it worked perfectly. This one is in a cliente site and seems to have all the right ports open. We use UFW and all the right ports are open.

I can't see your domain with HTTP from various parts of the globe.

Do you have a geographic based firewall blocking access from outside Brazil?

The Let's Debug test site is good for testing new setups. Right now connections to your domain times out


It's strange. We don't have any kind of blocking access for outside Brazil. I will ask the TI guys from the company I am working for to check all the routers and firewalls again.


Looks very likely a geographic based firewall


Thank you! I gonne ask my customer to check this with their Internet provider.


Mike you was right! they found a firewall in one of the routers blocking some international traffic. All right now! Thank you so much for your time and help!!!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.