Problem binding to port 443: Could not bind to IPv4 or IPv6


#1

error from cronjob which is trying to renew the cert on 2 domains on this server.

My domain(s) is: whmcs.topline.cloud & whm.topline.cloud

I ran this command: /opt/letsencrypt/letsencrypt-auto renew

It produced this output:
Processing /etc/letsencrypt/renewal/whmcs.topline.cloud.conf
Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator standalone, Installer None
Renewing an existing certificate
Performing the following challenges:
tls-sni-01 challenge for whmcs.topline.cloud
Cleaning up challenges
Attempting to renew cert (whmcs.topline.cloud) from /etc/letsencrypt/renewal/whmcs.topline.cloud.conf produced an unexpected error: Problem binding to port 443: Could not bind to IPv4 or IPv6… Skipping.

My web server is (include version): cPanel (latest)

The operating system my web server runs on is (include version): CentOS7

My hosting provider, if applicable, is: linode

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel

Logfile:
2018-06-04 16:18:05,187:ERROR:certbot.renewal:All renewal attempts failed. The following certs could not be renewed:
2018-06-04 16:18:05,187:ERROR:certbot.renewal: /etc/letsencrypt/live/whmcs.topline.cloud/fullchain.pem (failure)
/etc/letsencrypt/live/whm.topline.cloud/fullchain.pem (failure)
2018-06-04 16:18:05,189:DEBUG:certbot.log:Exiting abnormally:
Traceback (most recent call last):
File “/opt/eff.org/certbot/venv/bin/letsencrypt”, line 11, in
sys.exit(main())
File “/opt/eff.org/certbot/venv/lib/python2.7/site-packages/certbot/main.py”, line 1315, in main
return config.func(config, plugins)
File “/opt/eff.org/certbot/venv/lib/python2.7/site-packages/certbot/main.py”, line 1228, in renew
renewal.handle_renewal_request(config)
File “/opt/eff.org/certbot/venv/lib/python2.7/site-packages/certbot/renewal.py”, line 443, in handle_renewal_request
len(renew_failures), len(parse_failures)))
Error: 2 renew failure(s), 0 parse failure(s)


#2

Hi @jimlongo56,

The standalone authenticator is meant for use when you don’t have an existing web server on your machine, or when you don’t want to use it during the authentication process. It creates its own temporary web service which conflicts with any running web server process, so if you do have a web server, you’ll have to stop the web server process before renewing with standalone. Among other options, this can be done with --pre-hook "service nginx stop" --post-hook "service nginx start" or the equivalent for your web server.

Most cPanel users don’t need to use Certbot at all, because they can instead use AutoSSL inside of cPanel as an alternative to Certbot that’s better-integrated with cPanel. Do you have access to this feature?


#3

Thank you I’ll do that.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.