Problem binding 443 when renewing cert


#1

Hey guys, I’m strugglging finding a solution for this error, basically my cert expired and I’m trying to renew it:

OS: Ubuntu 18.04
COMMAND: certbot renew


#2

Hi @EncryptionXYZ

you have one certificate created / renewed today: The panel.humbleservers.com is new.

https://transparencyreport.google.com/https/certificates?cert_search_auth=&cert_search_cert=&cert_search=include_expired:false;include_subdomains:false;domain:panel.humbleservers.com&lu=cert_search

One part of the problem: You are using tls-sni-01 validation + the standalone Authenticator. “Standalone” creates an own webserver. But if your webserver is running, port 443 is blocked.

You can stop your own webserver, renew and start your webserver again.

But (second problem): The tls-sni-01 - validation is deprecated, supports ends 2019-02-13.

So you should switch to another authenticator.

You have a running nginx, so try to renew the dev - subdomain with the --nginx - option.

Your panel is now ok, the certificate is already installed and works.

Certificates found

CN=panel.humbleservers.com 18.11.2018 16.02.2019 panel.humbleservers.com - 1 entries
CN=Let’s Encrypt Authority X3, O=Let’s Encrypt, C=US 17.03.2016 17.03.2021
CN=DST Root CA X3, O=Digital Signature Trust Co. 30.09.2000 30.09.2021

#3

This has been solved, what I did was stop nginx and put in the command and then started nginx again and did a hardware reboot and everything seems to be working fine.


#4

You’re running Linux. A hardware reboot should almost never be necessary…


#5

You should also not have to stop nginx to update the certs.
Have you tried using the nginx plugin?