Problem after revoking SSL

I recently installed 2 certificates for two of my domains on hosted on the same IP, which caused problem: when I visit domain A, the browser will show a warning that the certificate is not configured right and is only certified for domain B.

Right now, I revoked SSL for domain A following this guide . When I visit it, a wordpress site, it’s showing right (http and not https); but when I visit the backend, domain A/wp-admin, it will show the same warning as above.

Could anyone advise what the problem is?

Thank you!

Revocation was almost certainly not what you wanted. Revocation says basically that the CA (Let’s Encrypt) no longer believes the certificate is trustworthy. You would use this if your private key data was stolen, or disclosed by accident, to prevent bad guys from using the certificate to impersonate you. It might also be used if the certificate itself was obtained fraudulently somehow.

What you need to do is change the configuration of your server so as to achieve whatever your actual goal is. If you’ve gone off the idea of HTTPS, you will need to remove configuration that “redirects” people, and if you used HSTS it will take some time (possibly months) for that to wear off because it configures other people’s web browsers, semi-permanently.

It should be possible to have either two different certificates, with the right one presented for each site, or a single certificate valid for all the names involved if that’s acceptable. But configuring this in your web server can be unexpectedly complicated to get right, and you didn’t specify even which web server software you use, so I can’t be of much further help.

  1. If you have used webroot , You have forced your url to use ssl via .htaccess or web server configs .Disable rewrite rules .[Also check You have mentioned correct certs path in web configurations if its enabled with ssl]
  2. If you have used direct certbot command to automatically enable ssl config, After revoking certs , make sure that the le-domain.conf is disabled.
    3.If you have changed wp-options inside db , for ex: site url and home url to
    change it and check it out .As soon as you change check it in private window / incognitio mode of a browser.

Dear Gotham,

Thank you for your help. Your point 3 solved my problem. I used a plugin before to update http to https. After I change the home and site url back, it’s now working well.

Also thank you @tialaramex, your answers help me know more about my websites.

Appreciate your help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.