Php -route not working after add ssl

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
It produced this output:
404 not found
My web server is (include version):

The operating system my web server runs on is (include version): ununtu 18.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

i use wildcard and certificate work fine
but after i add ssl php route not work
i use php and nginx

if anyone can support

if any one have suggest

Does it still work via HTTP ?

i do redirect http to https

Not from what I can see:

curl -Iki http://{redacted}/app
HTTP/1.1 404 Not Found
Server: nginx/1.14.0 (Ubuntu)
Date: Sun, 26 Apr 2020 23:29:35 GMT
Content-Type: text/html
Content-Length: 178
Connection: keep-alive

Then you should compare the two vhost configs.

there is no vhost for it is wildcard config

The HTTP vhost worked.
Some (removed) wildcard HTTPS vhost works.
The new HTTPS vhost fails.

Compare a working one with the one that fails.
[there must be some difference]

i haven’t got your point

Your new vhost config fails.
It should have been a copy of the working config (only adding TLS).
But it fails, so I can only assume the copy is bad or incomplete.
There must be a difference between the working config and the failing config.


You never had a working config …

may be the second one is the most probably

Then adding TLS did not break it.
It never worked.

what you suggest to sort this

There is nothing that this forum can do to fix your config
We can only fix your TLS cert problems.
You have no TLS cert problem

You have a programming problem.

can you check inbox to check

I don’t understand your request.
The problem appears to be in your coding.
This is not a PHP, nor NGINX, programming forum.
You should review the code and fix it or search the web for coding help to fix it or maybe there is another forum that can help you fix it.

please can you remove domain name from ur reply thanks alot @rg305

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.