Permission denied error while running with sudo

My domain is:

I ran this command:
sudo certbot certonly --nginx -d

It produced this output:
No output in the console itself.

My web server is (include version):
Nginx 1.18.0

The operating system my web server runs on is (include version):
Ubuntu 20.04.3 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
Yes, Proxmox 7

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
Nothing returned into console, thought version was installed today following the certbot guide. Certbot Instructions | Certbot

Hi @TheTrueColonel and welcome to the LE community forum :slight_smile:

Which guide exactly did you follow?

1 Like

Thank you. I used this guide: Certbot Instructions | Certbot

That's ... strange.

Are you trying to run Certbot from a web-based (browser) console by any chance?

1 Like

I'm running it from the web console in Proxmox.

I see. I have access to a Proxmox cluster, so I can try reproduce this issue some time in the coming week.

In the meantime:

  • If you can run it in a real SSH terminal, I think that should work around the problem.

  • Adding --non-interactive could be another workaround, but you may need to add some other flags which Certbot would otherwise prompt you about, like:

    --agree-tos -m --no-eff-email

Once I got in using PuTTY, it worked flawlessly, thanks!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.