Passenger directives in nginx.conf causing errors

Why does Certbot say unknown directive for every passenger directive when passenger is suggested in every search result for ruby on rails with nginx I can’t even find docs for setting up rails with nginx without passenger or unicorn Gimme a break

This is not really the best method for asking help. Perhaps passenger directives aren't that common among the regular certbot users or developers.

If you would have made a well formatted bug report, it might help developers to improve certbot. But unfortunately, your post is more of a frustrated rant. Not very helpful.

May I invite you to give a more un-frustrated 'bug report'? Normally, when posting in the "Help" section of the forum, you are provided with a questionnaire, which we use to give you more useful help:

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

There

https://community.letsencrypt.org/t/migrating-from-sslforfree/93263/18

is your Topic. Please don't start different topics with the same problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.