Packaging Certbot for Mageia Linux


I’m packaging Certbot + plugins for Mageia Linux. Everything went smooth with Certbot itself, we’ve even managed to package the docs (something that even Fedora/RHEL guys failed to do :slight_smile: ) However, I’ve got a couple of questions regarding certbot-apache.

  1. Mageia is very similar to Fedora in terms of FS layout; even OS detection in certbot_apache/ might have worked (our LIKE property says “mandriva fedora”), but in fact we use a slightly different layout for Apache configs.

Specifically, vhost_root is different:

Fedora: /etc/httpd/conf.d
Mageia: /etc/http/conf/sites.d (or vhosts.d, which is a symlink to sites.d)

From what I’ve learned yet, we’ll have to apply an RPM patch to add proper Mageia support to certbot_apache/ My question is: certbot_apache/augeas_lens/httpd.aug contains paths too, do we need to patch it?

  1. We’ve recently updated our python-augeas to 1.0.2, and certbot-apache requires 0.5.0. (Tried to override it, and got multiple test failures with 1.0.2.) Any chances to have certbot-apache support recent python-augeas in the near future? Or the only way is to rollback our package version to 0.5.0?

Thanks in advance!

Hi @bmw, could you please take a look at this question?

Hi @mitya! Thanks for packaging Certbot for Mageia and reaching out to us.

  1. I’d be happy to modify upstream to include Mageia. Is the only difference from CLI_DEFAULTS_CENTOS in that file the vhost_root? Should one of sites.d or vhosts.d be preferred over the other? Modifying CLI_DEFAULTS_CENTOS should work for you for now though.

You don’t need to modify httpd.aug. Certbot will work with Augeas at runtime to include the other files it needs to parse.

  1. We’ve removed the requirement on python-augeas<=0.5.0 in our master branch, but we haven’t done a release including this yet (see We should be doing a release late next week, but if you modify certbot-apache's file to look like the following and rebuild/reinstall the package, all tests should pass with python-augeas 1.0.2. If they don’t what errors are you seeing?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.