Openlitespeed will not restart

i used one click instal of openlite speed and lets encrypt.
the following file has been created in cron
0 */12 * * * root test -x /usr/bin/certbot -a ! -d /run/systemd/system && perl -e 'sleep int(rand(43200))' && ce$ --deploy-hook "/usr/local/lsws/bin/lswsctrl restart"

the certificate gets renewed but openlitespeed needs a manual restart

when i run
~# certbot --force-renewal
i get an error so wondering if this error is somehow preventing the restart.

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Certbot doesn't know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run "certbot certonly" to do so. You'll need to manually configure your web server to use the resulting certificate.

I am running certbot 1.14.0

Thank you for any input.

Hi @gniady

please read your command.

If the renew works, but the restart not, that part

may not work. Exists that script? Works it? Test it.

The script is there and that's what i have to do manually to restart the server after the update.
Is there a way to test the renew command with the hook? shoudl i test it with --force-renewal?

i tested with --dry-run and it goes fine though cycles and skips it since not renewed so all looks good. Maybe it needed some updated since i just recently updated to latest version from 0.3.

That's mostly fatal. Your script doesn't work, certificate creation works. That's the wrong place to find your error.

That's unrelevant. Please read the documentation

--deploy-hook commands are not called.

You ignore the problem. It's not a Certbot problem, it's a problem with your additional script you have to fix.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.