Only one certificate generated, others missing


#1

Please fill out the fields below so we can help you better.

I have many domain under the same server:
this domain SSL works after certbot installation: http://designexcellent.com
this don’t work, it shows the main website’s certificate http://userexperiencestudio.com

I followed this guide: https://certbot.eff.org/#ubuntutrusty-apache
The strange thing is that it didn’t produce errors, it asked me to select numbers of all the websites I want to create a certificate, and I selected more than 10 but in etc/letsencrypt/live there is only one certificate for http://designexcellent.com

My operating system is (include version): Ubuntu 14.04

My web server is (include version): Apache 2

My hosting provider, if applicable, is: Digitalocean

I can login to a root shell on my machine


#2

You have obtained one certificate, for all the domains, so it will work for any of the 14 domains you have listed. userexperiencestudio.com is using a valid certificate


#3

But it doesn’t seems so, from all the browsers it says: Your connection to this site is not fully secure.
The same for all the others


#4

That is not because of the certificate. That is because you include items via http (which is not secure). Hence you get that warning.

The two items I can see are;

Insecure URL: http://userexperiencestudio.com/wp-content/uploads/2017/01/workings-1.jpg?id=2980
Insecure URL: http://userexperiencestudio.com/wp-content/uploads/2017/01/logo-web.png

#5

Fantastic, that’s the issue. Thank you


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.