Odd redirect prevents second cert use

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:


I ran this command:

certbot certonly -d taskbang.com --server "https://dv.acme-v02.api.pki.goog/directory" --standalone

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Requesting a certificate for taskbang.com

Successfully received certificate.
Certificate is saved at: /etc/letsencrypt/live/taskbang.com/fullchain.pem
Key is saved at: /etc/letsencrypt/live/taskbang.com/privkey.pem
This certificate expires on 2023-10-07.
These files will be updated when the certificate renews.
Certbot has set up a scheduled task to automatically renew this certificate in the background.

If you like Certbot, please consider supporting our work by:

My web server is (include version):

Apache/2.4.56 (Debian)

The operating system my web server runs on is (include version):

Debian 11

My hosting provider, if applicable, is:

Google Cloud

I can login to a root shell on my machine (yes or no, or I don't know):


I'm using a control panel to manage my site (no, or provide the name and version of the control panel):


The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

certbot 2.6.0

The issue:

The first site I set up was dowerhousecats.com. With a single site, never would have bumped into this issue. Upon setting up the cert for the second site, the issue presents itself.

The root IP for this is:

During the first cert installation, all HTTPS traffic began being redirected to https://dowerhousecats.com. It ignores all of my configurations.

If I visit any of these URLs, it redirects to https://dowerhousecats.com:

I can't actually visit https://taskbang.com. You'll also notice that there is a security flag, as it is trying to use the cert for dowerhousecats.com all the time.

I did a search, but could not find anything related. If you can help, much appreciated!

Hi @kmwill23, and welcome to the LE community forum :slight_smile:

As with all things Apache, I would recommend that you start the troubleshooting with:
sudo apachectl -t -D DUMP_VHOSTS


That has to be record time! Thanks, your note led to the solution.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.