No Valid IP with cloudflare DDOS prevention

Have a domain from Godaddy, the server is located on an AWS. And I have my traffic routed through cloudflare to prevent DDOS, I think this is preventing me from getting the cert-bot to work.
URL: reactpannel.dzwxgames.com

Hi,

Yes, this might be the issue.

Can you share us your error output ,try enable “Development mode” and run certbot again? (Only if you are using http-01 validation)

Thank you.

Cloudflare’s reverse proxy service is incompatible with Let’s Encrypt TLS-SNI-01 validation, which is being phased out anyway. But I think that should give a different error message.

And it’s compatible with HTTP-01 validation.


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

I ran this command: sudo certbot -apache

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org

Which names would you like to activate HTTPS for?

1: admin.dzwxgames.com
2: www.admin.dzwxgames.com
3: reactpannel.dzwxgames.com
4: www.reactpannel.dzwxgames.com

Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel):
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for admin.dzwxgames.com
http-01 challenge for www.admin.dzwxgames.com
http-01 challenge for reactpannel.dzwxgames.com
http-01 challenge for www.reactpannel.dzwxgames.com
Enabled Apache rewrite module
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. www.admin.dzwxgames.com (http-01): urn:acme:error:unknownHost :: The server could not resolve a domain name :: No valid IP addresses found for www.admin.dzwxgames.com, www.reactpannel.dzwxgames.com (http-01): urn:acme:error:unknownHost :: The server could not resolve a domain name :: No valid IP addresses found for www.reactpannel.dzwxgames.com

IMPORTANT NOTES:

My domain is: dzwxgames.com

My web server is (include version): GNU/Linux 4.4.0-45-generic x86_64

The operating system my web server runs on is (include version): Ubuntu 16.04.3 LTS

My hosting provider, if applicable, is: Amazon AWS

My domain provider is: Godaddy

My ddos prevention provider is: Cloudflare (Currently dissabled)

I can login to a root shell on my machine (yes or no, or I don’t know): Yes.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No.

uname -a:Linux amazonaws.dzwxgames.com 4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

DNS: https://gyazo.com/18a149cbf93ecab68a80027efe556e17

You need to create A records for “www.admin” and “www.reactpannel”, just like the other DNS records.

Or remove them from the request, if you were never planning on using those domains. (Type in “1 3” when asked to select names)

1 Like

Wonder why my main domain also dosent show up in that list. Cant i just make a *.dzwxgames cert?

It’s generating the list by parsing your web server configuration—maybe the base domain name isn’t currently listed as a server name or alias in any virtual host?

Yes, once Let’s Encrypt introduces support for wildcards and clients also support it. This hasn’t happened quite yet.

However, wildcard certificates don’t automatically cover the base domain name: *.dzwxgames.com would cover foo.dzwxgames.com but not dzwxgames.com itself (because the wildcard only refers to subdomains).

ok great got it working, but my next question is, what is the option to only enable https redirect only on some subdomains

Cause it seems to redirect for all sub domains now, regardless if it has a Cert.

Then you’ll need to set a rule on your local server rather than cloudflare.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.