No valid IP addresses found for domain

Shouldn't this be your servers' internal IP?:
image
Something more like: 192.168.x.x

2 Likes

I have tried with private IP address as well. Same error :confused:

1 Like

image
Then your first task is to move the HTTP port of the router to some other number (not 80 & not 443).
If that is NOT possible... then "that is NOT possible".

3 Likes

Did a quick search on that error message and found this. How old is your firmware? Would this fix it?
https://www.geekzone.co.nz/forums.asp?forumid=81&topicid=245485

Partial quote from Feb 2019:
Since I have had the new NF18ACV router I am unable to successfully change the HTTP management port on the router. By default it is on port 80. However I want to run a webserver which requires NAT on 80.

3 Likes

Excellent find @MikeMcQ !
If that doesn't do the trick...
This workaround might be for a different router model but it is worth looking into:
https://www.geekrant.org/2020/04/26/setting-up-a-public-facing-webserver-behind-a-netcomm-nf18acv/

If everything fails, I'd speak with the ISP and see if they can provide an alternate router that can do what you need.

3 Likes

I tried updating the firmware yesterday and that broke my internet, so I had to downgrade it to be original version.

Thank you @rg305 for finding that. I managed to change the port.
image

The problem is that the web server is still unreachable when using the public IP address.
Now I can add port forwarding, but even that doesn't help.
It looks like the only option will be getting another router.
Anyways, thank you for all the help :slight_smile:

2 Likes

I'm :confused:
If you were able to change the routers HTTP port (and disable the WAN side ports) how is it still saying?:
image

OR
Is it some new and different error msg now?

I think I know what's going on!
When you set the "HTTP service" to some other port, you moved that service from the router. [GOOD]
But...
When you went to create port forwarding you used "HTTP service" - which matches what the router is still using! [BAD]
image

You need to create a new additional service for HTTP80 and use that one for the port forwarding :slight_smile:

2 Likes

There is no error message anymore, I can add the configuration now.

But if you try browsing to http://203.211.110.83/ it does not work.

1 Like

Sorry I see that it is WAN:
image
But I would choose "Custom Service" instead.
Call it "AnythingUnique" and make sure it uses TCP port 80.

2 Likes

Same problem :confused:

1 Like

grrrrrr....

[need more :beer: and must find a bigger :hammer: ]

Have you rebooted the router since the HTTP was removed from it?

2 Likes

Hahaha
Rebooted the router. Still no luck.
I'll take a break.

3 Likes

I give up!
I'd ask the ISP for another model.
OR for their help.

2 Likes

No problem. Thank you for helping :slight_smile:

4 Likes

Just a passing thought as I read the posts... Do you see DMZ anywhere in your router? You would have to tighten the firewall on the web server of course.

2 Likes

I've tried that too.
It seems to be bug with the firmware version, but if I upgrade the firmware the Internet stops working. I'll contact my ISP.
Thank you

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.