No valid IP addresses found + check that a DNS record exists

Hello. I’m a novice, so please go easy on me! I’ve added two A records for my domain (www and non).

My domain is: naylam.com

I ran this command: sudo certbot --nginx -d naylam.com -d www.naylam.com

It produced this output:

My web server is (include version): nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 18.04.3 LTS

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don’t know): Yes.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

1 Like

You’ve added an A record at DigitalOcean’s DNS service. But your domain is not actually using it.

naylam.com.             172800  IN      NS      ns1.bdm.microsoftonline.com.
naylam.com.             172800  IN      NS      ns2.bdm.microsoftonline.com.
naylam.com.             172800  IN      NS      ns3.bdm.microsoftonline.com.
naylam.com.             172800  IN      NS      ns4.bdm.microsoftonline.com.

You need to either create the A records at the Microsoft DNS service that your domain is using, or you need to go to your domain registrar and change the nameserver settings to ns1.digitalocean.com, ns2.digitalocean.com and ns3.digitalocean.com.

3 Likes

Wow, how embarrassing. It’s all good now. Thanks a lot, Matt!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.