"No match found for cert-path" while revoking a certificate

My domain is:

I ran this command:

sudo certbot revoke --non-interactive --cert-path /tmp/certify_revoke_hBVaR2d3Vbo/live/www.dg1-test.jp/cert.pem --key-path /tmp/certify_revoke_hBVaR2d3Vbo/live/www.dg1-test.jp/privkey.pem --email sslcertificates@progmbh.com --preferred-challenges http --http-01-port=5002 --config-dir=/tmp/certify_revoke_hBVaR2d3Vbo --work-dir=/tmp/certify_revoke_hBVaR2d3Vbo --logs-dir=/tmp/certify_revoke_hBVaR2d3Vbo

It produced this output:

Saving debug log to /tmp/certify_revoke_hBVaR2d3Vbo/letsencrypt.log
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
No match found for cert-path /tmp/certify_revoke_hBVaR2d3Vbo/live/www.dg1-test.jp/cert.pem!

My web server is (include version): cert was issued using the command:

certbot certonly --standalone ${DOMAINS} --non-interactive --agree-tos --email ${CERTBOT_AUTH_EMAIL} --preferred-challenges http --http-01-port=${CERTBOT_BOT_PORT} --config-dir=${TMP_FOLDER} --work-dir=${TMP_FOLDER} --logs-dir=${TMP_FOLDER}

The operating system my web server runs on is (include version):
Ubuntu 18.04

My hosting provider, if applicable, is: /

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

certbot 0.28.0

Command’s exit code is 0, so it appears that something worked. When I check crt.sh it appears that the cert is revoked.

I would just like to know if “No match found for cert-path” is an error?

Thank you,
Valentin I.

I think what’s happening is that certbot is trying to delete the certificate files after revoking the certificate, but not finding them. It seems to find the files to delete by searching for a renewal configuration file. If you don’t have a renewal configuration file for that cert in the config directory, then I guess that would fail. But you might not care if it’s in /tmp as you’ll probably delete it soon anyway, and as you observed, the certificate has already been revoked at this point.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.