No access from outside

#21

Hello everyone,
I come back to you.
After reinstalling Debian + jeedom on my Raspberry then restored my backup, everything works, well almost.

Access from outside does not work anymore and I think it’s related to my certificate issues, knowing that prior to my certificate issues, this configuration worked.

My configuration
Box:
3434 (ext) ==> 443 (int Jeedom)

Jeedom:
Internal: http: // iplocal: 80
External: https: // ndd: 3434

If I try to access Jeedom from outside, the browser tells me “connection refused”.
No problem to access my NAS via the same ndd and another port.

Regarding the certificate, after running the command
sudo rm -rf /etc/pip.conf
then
./ certbot-auto --apache -d mydomainname

I got a message which told me that I had reached the limit.
Saving debug log to /var/log/letsencrypt/letsencrypt.log Plugins selected: Authenticator apache, Install apache Obtaining a new certificate An error occurred. : http://momotte.synology.me: see https://letsencrypt.org/docs/rate-limits/ ... Please see the logfiles in / var / log / letsencrypt for more details.

Can you help me ?
Mathieu

#22

Hi!

I also encountered this error, I just waited 7 days to reset the request limit, after that you may request a certificate again. Just sharing.

Regards,

Helbert

#23

hello,
I have to wait until tonight?
https://crt.sh/?q=momotte.synology.me

#24

Hi @JuergenAuer

This is not ssl issue, you should check 1st firewall rules. The firewall is allow to access port outside.

#25

Hi @OUARZA

letsencrypt is working on standard ports. So you should change your application/Jeedom ports.

#26

Hello,
The firewall is well configured.
80 <=> 80 Raspberry
443 <=> 443 Raspberry

I just tried a request again:

pi@raspberrypi:/etc $ sudo ./certbot-auto --apache -d momotte.synology.me
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Obtaining a new certificate
An unexpected error occurred:
There were too many requests of a given type :: Error creating new order :: too many certificates already issued for exact set of domains: momotte.synology.me: see https://letsencrypt.org/docs/rate-limits/
Please see the logfiles in /var/log/letsencrypt for more details.

Do you want the detail of /var/log/letsencrypt/letsencrypt.log ?
Thank you

#27

You have created certificates. So that works. But you don’t use these.

So creating the next certificate doesn’t help.

#28

@JuergenAuer,
How to recover a certificate that is already created or how to remove all certificates ?

#29

Champagne !!!

Congratulations! You have successfully enabled https://momotte.synology.me

1 Like