# Nginx Proxy Manager Internal Error while generate Certificate

**URL:** <https://community.letsencrypt.org/t/nginx-proxy-manager-internal-error-while-generate-certificate/185602>\
**Category:** Help\
**Created:** [October 4, 2022, 6:53am UTC](https://community.letsencrypt.org/t/nginx-proxy-manager-internal-error-while-generate-certificate/185602 "2022-10-04T06:53:10Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![mikadoman](https://avatars.discourse-cdn.com/v4/letter/m/a88e4f/32.png) [@mikadoman](https://community.letsencrypt.org/u/mikadoman)\
**Post date:** [October 4, 2022, 6:53am UTC](https://community.letsencrypt.org/t/nginx-proxy-manager-internal-error-while-generate-certificate/185602/1 "2022-10-04T06:53:10Z")

</div>

Hi I need help:  
I installed a new Nginx Proxy Manager and while generating a new Certificate I had an internal Error.  
The Output of the log is:  
[10/4/2022] [6:25:14 AM] [Nginx] › ℹ info Reloading Nginx

[10/4/2022] [6:25:20 AM] [SSL] › ℹ info Requesting Let'sEncrypt certificates for Cert #20: [cloud.abels-lehe.de](http://cloud.abels-lehe.de)

[10/4/2022] [6:25:20 AM] [SSL] › ℹ info Command: certbot certonly --config "/etc/letsencrypt.ini" --cert-name "npm-20" --agree-tos --authenticator webroot --email "[administrator@abels-lehe.de](mailto:administrator@abels-lehe.de)" --preferred-challenges "dns,http" --domains "[cloud.abels-lehe.de](http://cloud.abels-lehe.de)"

[10/4/2022] [6:25:22 AM] [Nginx] › ℹ info Reloading Nginx

[10/4/2022] [6:25:22 AM] [Express] › ⚠ warning Command failed: certbot certonly --config "/etc/letsencrypt.ini" --cert-name "npm-20" --agree-tos --authenticator webroot --email "[administrator@abels-lehe.de](mailto:administrator@abels-lehe.de)" --preferred-challenges "dns,http" --domains "[cloud.abels-lehe.de](http://cloud.abels-lehe.de)"

Saving debug log to /var/log/letsencrypt/letsencrypt.log

Certificate did not match expected hostname: [acme-v02.api.letsencrypt.org](http://acme-v02.api.letsencrypt.org). Certificate: {'subject': ((('commonName', '[mail.abels-lehe.de](http://mail.abels-lehe.de)'),),), 'issuer': ((('countryName', 'US'),), (('organizationName', "Let's Encrypt"),), (('commonName', 'R3'),)), 'version': 3, 'serialNumber': '03ED0FDF7B872CCE146FF12DEC0355B11233', 'notBefore': 'Aug 15 02:34:00 2022 GMT', 'notAfter': 'Nov 13 02:33:59 2022 GMT', 'subjectAltName': (('DNS', '[autodiscover.abels-lehe.de](http://autodiscover.abels-lehe.de)'), ('DNS', '[mail.abels-lehe.de](http://mail.abels-lehe.de)')), 'OCSP': ('[http://r3.o.lencr.org](http://r3.o.lencr.org)',), 'caIssuers': ('[http://r3.i.lencr.org/](http://r3.i.lencr.org/)',)}

An unexpected error occurred:

requests.exceptions.SSLError: HTTPSConnectionPool(host='[acme-v02.api.letsencrypt.org](http://acme-v02.api.letsencrypt.org)', port=443): Max retries exceeded with url: /directory (Caused by SSLError(CertificateError("hostname '[acme-v02.api.letsencrypt.org](http://acme-v02.api.letsencrypt.org)' doesn't match either of '[autodiscover.abels-lehe.de](http://autodiscover.abels-lehe.de)', '[mail.abels-lehe.de](http://mail.abels-lehe.de)'")))

Ask for help or search for solutions at [https://community.letsencrypt.org](https://community.letsencrypt.org). See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

[10/4/2022] [6:38:56 AM] [Nginx] › ℹ info Reloading Nginx

[10/4/2022] [6:41:18 AM] [Nginx] › ℹ info Reloading Nginx

Can anyone help me?  
Thanks!

---

<div class="post-metadata">

**Author:** ![rg305](https://sea3.discourse-cdn.com/letsencrypt/user_avatar/community.letsencrypt.org/rg305/32/91314_2.png) [@rg305](https://community.letsencrypt.org/u/rg305)\
**Post date:** [October 4, 2022, 1:53pm UTC](https://community.letsencrypt.org/t/nginx-proxy-manager-internal-error-while-generate-certificate/185602/2 "2022-10-04T13:53:25Z")

</div>

Hi @mikadoman, and welcome to the LE community forum 🙂

> [@mikadoman](#):
>
> Certificate did not match expected hostname: [acme-v02.api.letsencrypt.org](http://acme-v02.api.letsencrypt.org). Certificate: {'subject': ((('commonName', '[mail.abels-lehe.de](http://mail.abels-lehe.de)'

That looks like the outbound HTTPS requests to "`acme-v02.api.letsencrypt.org`" are being proxied by a system that has a cert for "`mail.abels-lehe.de`".

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/letsencrypt/original/3X/c/a/ca6c06ea1ea201324bba7048c6841ce60236468d.png) [@system](https://community.letsencrypt.org/u/system)\
**Post date:** [November 3, 2022, 1:54pm UTC](https://community.letsencrypt.org/t/nginx-proxy-manager-internal-error-while-generate-certificate/185602/3 "2022-11-03T13:54:11Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
