Nginx Proxy Manager Cert not working

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
I ran this command:
I asked the Nginx Proxy manager to make a wildcard certificate with DNS Challenge to Trans IP
It produced this output:

Error: Command failed: certbot certonly --config "/etc/letsencrypt.ini" --cert-name "npm-9" --agree-tos --email "[redacted]" --domains "*" --authenticator dns-transip --dns-transip-credentials "/etc/letsencrypt/credentials/credentials-9"
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Encountered exception during recovery: RuntimeError: The private key doesn't exist
An unexpected error occurred:
RuntimeError: The private key doesn't exist
Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

    at ChildProcess.exithandler (node:child_process:402:12)
    at ChildProcess.emit (node:events:513:28)
    at maybeClose (node:internal/child_process:1100:16)
    at Process.ChildProcess._handle.onexit (node:internal/child_process:304:5)

My web server is (include version):

The operating system my web server runs on is (include version):
Ubuntu 22.04 LTS
My hosting provider, if applicable, is:
Trans IP
I can login to a root shell on my machine (yes or no, or I don't know):
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hi @RickvDi, and welcome to the LE community forum :slight_smile:

Unfortunately that default message is not the best advice for this problem.
NPM is not covered well [nor regarded well] in this forum.
If they have any support channels, I would try them first.


I solved this error forgot to add the key to the file
Now I get some other error but that is probably a Trans IP problem

You could post the error here.
OR search through the forum for that error and maybe someone has already done the math.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.