Nginx fails to start inside container

Nginx fails to start inside container because of missing SSL certificate on new docker-compose install.
PS: SSL certificates resides in the mentioned path.
Looking for solution.
Thanks

You might want to give us a little bit more information to work with.

I’m not sure how you’ve ended up in this “Help” section exactly, but if you selected it as a first choice for the section menu, you would have been presented with the following questionnaire:

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Thanks for your attention.
Sorry, i can’t share my domain name. This is the error I,m seeing in the logs.
"cannot load certificate “/etc/letsencrypt/live/domainname/fullchain.pem”

You might not be able to get help here without sharing your domain name, but you should at least try answering all of the other questions in the form.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.