Newly Generated Certificate Not Verified


#1

Hi,

Just got my email for the Beta and I have tried it out and I got as far as getting the certificates created and installed, so now when I do go to my website, it does indeed show there’s an SSL, but it still says it’s not verified.

I was under the impression it should be, and provide the green padlock (in Chrome at least). Not sure what I’m doing wrong - if anything.

The program created my SSL file (cmellor.uk-le-ssl.conf) and in it:

<IfModule mod_ssl.c>
<VirtualHost *:443>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin cmellor@gmail.com
        DocumentRoot /var/www/cmellor.uk/html

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
SSLCertificateFile /etc/letsencrypt/live/www.cmellor.uk/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/www.cmellor.uk/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateChainFile /etc/letsencrypt/live/www.cmellor.uk/chain.pem
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
</IfModule>

Any ideas what it could be? I’m happy to provide any further documents or Logs if needed.

Thank you.


#2

what does chrome say for the cert info?

I tried to check your site (as it looks in the log) but no connection.


#3

That means your installation was successful… As stated here: https://letsencrypt.readthedocs.org/en/latest/intro.html.

This beta release is for testing only. There’s no “Trusted Authority” yet - the certificate is actually issued by “happy hacker fake CA” and can not yet be used on production sites, but: “Browser-trusted certificates will be available in the coming months”


#4

Possibly silly question but did you a2ensite the new conf file - I almost forgot about that. Otherwise it should be working - it is for me: https://agmckee.uk/


#5

Thanks for the info. Makes perfect sense


#6

But… my reply was actually wrong. I overlooked a clear instruction in the invitation email - perhaps you did too? Try to re-issue, specifying the production URL:

./letsencrypt-auto --agree-dev-preview --server  https://acme-v01.api.letsencrypt.org/directory auth

Now I have a green padlock and a Trusted Authority