Newbie Help With install please, Memory Loss


#1

Greetz to all

First I want to thank you for offering SSL and having an awesome community here.
A little brief about me . I run a server that offers cheap hosting and lots of free services to church(s) and individuals that cant afford hosting , I am struggling from memory loss due to getting shot in the head a year ago (Robbery) I cant seem to think straight and I must be doing something wrong.
I would like to have ssl on my main server and a few subs that are part of my server. then later can offer free certs to the ones buying hosting

here is my server information and I do have root in shell

Server Version: Apache/2.4.18 (Unix) OpenSSL/1.0.1e-fips mod_bwlimited/1.4
Server MPM: prefork
Server Built: Jan 1 2016 17:21:23
CENTOS 6.8 x86_64 standard – server
WHM 58.0 (build 32)

my error after following the automated certbot is:

/root/.local/share/letsencrypt/lib/python2.6/site-packages/certbot/main.py:504: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
return e.message
Certbot doesn’t know how to automatically configure the web server on this syste m. However, it can still get a certificate for you. Please run “certbot-auto cer tonly” to do so. You’ll need to manually configure your web server to use the re sulting certificate.
root@server [~]#
root@server [~]# ./path/to/certbot-auto --apache
-bash: ./path/to/certbot-auto: No such file or directory

my entire shell output is here: http://www.wepaste.com/btcguy/
is there a simpler way ? perhaps a WHM Module ?
can anyone please help me with what commands I need to issue please.

Thank you so much.
BTCGUY


#2

Hi,

Cpanel / WHM now has an official plugin - https://blog.cpanel.com/announcing-cpanel-whms-official-lets-encrypt-with-autossl-plugin/

You may need to update your cpanel ( /scripts/upcp ) and enable letsencrypt ( /scripts/install_lets_encrypt_autossl_provider ) then go into WHM and the autossl page. It’s all very straightforward and automatic from there.


#3

I would Like to thank you so much for providing me with this help …

Thank You


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.