New Certificate on Cloned Server


#1

Today, I created a new cloud server (staging2..com) that my client wants to use for their new staging site.
The new cloud server is an exact clone of the current (old) staging server (staging..com)
Cloud Server OS is Ubuntu 14.04.
The certificate on staging2 was generated on the old staging cloud server.
The certificate doesn’t expire until December.
On staging2, I tried to generate a new certificate that would point to staging2..com, but I get this error:
The following certs are not due for renewal yet:
/etc/letsencrypt/live/staging2..com/fullchain.pem (skipped)
No renewals were attempted.

I used this command:
root@staging2:/etc/letsencrypt# /opt/letsencrypt/letsencrypt-auto renew

I have tried various ways to add force, but none work. I would appreciate any help you can provide me to force LetsEncrypt generate a new certificate that will point to the staging2 domain. Thank you!


#2

If this is a full clone of the server, then doing a renew will the cert named in the config - which would be staging…com not staging2…com.

If you want a cert for staging2…com then you would need to create a new cert, not renew.


#3

Agreed with @serverco that you will need a new, separate certificate if the underlying domain name is different. (If it’s different, the renew process probably won’t even work, because it will try to prove control of the original domain name, which the new server probably doesn’t have the ability to do!)

If you’re absolutely sure that the new server is pointed to by the same names as the original server and that you need to renew the existing certificate (getting an exactly equivalent certificate for the same names), you should be able to use letsencrypt-auto renew --force-renew for that. But as @serverco says, this isn’t likely to be what you need to do. :slight_smile:


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.