Network error - message when try to run the agent

Hello,

I am keep getting "Network error" message and challenge file is not created on the server.
The error is when I run the agent on Domino server 9.01 FP9.
Same configuration on the same server was working for me on October 2020 and failed to renew on 11/1/2021 .

tell amgr run 'iswcloud/le4d.nsf' 'letsencrypt'

Any ideas how can I debug the issue ?

Processing configuration document: 'D49E3553320631234925865B0004A860'.
Using Html directory: domino/html
Requesting certificates.
Writing file: 'E:\IBM\Domino\data\iswcloud\le4d-workdir\D49E3553320631234925865B0004A860\user.key'
Session URL: acme://letsencrypt.org
Network error
Writing file: 'E:\IBM\Domino\data\iswcloud\le4d-workdir\D49E3553320631234925865B0004A860\domain.key'
OUPS!! Something went wrong!

Thanks,
Alon

Hi @alonkedmi

I don't know how that client works.

Sure it isn't a harddisk problem with E:\ - damaged, no free space etc.?

Is there a better log or something like a -v / -verbose - option?

Is there an update of that client?

2 Likes

Thanks @JuergenAuer
All is ok in regard with disks and it worked fine for the first time, it generated KYR file without any issues.
But when I try to run it again it fails.
Actually I tried on the second server and failed as well, so I wonder is a networking issue or something on the client side.
I checked F/W, DNS and all looks ok.

I just don't know how to debug it properly ?

1 Like

I was able to see from F/W that call back request I guess for challenging process is via port 443.

It may fail because SSL expired, is there any way to force it via port 80 only ?

1 Like

LE will always try HTTP.
If you are seeing HTTPS from LE implies it is following a redirection.

1 Like

Your client uses only port 443 / https to connect the Letsencrypt API.

But the check of your domain starts with port 80 / http.

So outgoing https is required to use any client.

1 Like