Need Help - To Delete a Wildcard SSL

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: track.ctmoffers.com

I ran this command: https://www.ssllabs.com/ssltest/analyze.html?d=track.ctmoffers.com

It produced this output: |Valid from|Wed, 22 May 2019 07:55:48 UTC|
| — | — |
|Valid until|Tue, 20 Aug 2019 07:55:48 UTC (expired 3 days, 9 hours ago) EXPIRED|

My web server is (include version): Siteground

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Siteground

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): don’t know

I initiated a deletion about 10 hours ago - but still getting same error

1 Like

Hi @colmac1000,

It sounds like you did this within Siteground’s own interface and using their own tools. If so, you should most likely ask Siteground for help with that.

1 Like

Thank you Schoen. I am and their support are normally first class - we are struggling. Hence my post. I have them looking at it again. The main domain looks fine - but the sub domain continues to be a problem.

1 Like

Unfortunately, “deleting” a certificate is purely a hosting-environment-specific action; the certificate authority literally knows nothing about it and is not involved in it at all. That’s why the success or failure of this task will depend only on the details of the hosting environment and what it’s trying to do.

Hi @colmac1000

why do you want to delete that certificate?

Create a new certificate, then replace the expired certificate. Then you can delete it.

But deleting a certificate that is used is always bad. That may break your configuration.

PS: Checked your domain now there is another certificate

CN=*.sgcpanel.com, OU=Domain Control Validated
	09.04.2019
	08.06.2020
expires in 290 days	*.sgcpanel.com, sgcpanel.com - 2 entries

And there are two active certificates ( https://check-your-website.server-daten.de/?q=ctmoffers.com#ct-logs ):

Issuer not before not after Domain names LE-Duplicate next LE
Sectigo RSA Domain Validation Secure Server CA 2019-08-22 2020-08-22 track.ctmoffers.com
1 entries
Let’s Encrypt Authority X3 2019-07-21 2019-10-19 *.ctmoffers.com, ctmoffers.com
2 entries
Let’s Encrypt Authority X3 2019-05-22 2019-08-20 *.ctmoffers.com, ctmoffers.com
2 entries
1 Like

Thank you Juergen,
the linked record suggests that there is some residue of wildcard certificates still on Siteground.
I have forwarded to their support.

They are bogged down in the fact that the track.subdomain has a CNAME record to RedTrack - tracking software. However I think it is because the previous certificates were raised as wildcards is causing the issue.

Your help is really appreciated - the more information I get the better my chance of finding the resolution - so an education! I have bookmarked the URL of the analyzing tool - very useful!

Colin

Hi @colmac1000,

Please refer to ticket 3233215 where our team has addressed the issue in more details. We have double-checked things on the server end and we can confirm that the expired SSL is not loaded from our server.

Our investigation revealed that the domain for which the expired Let’s Encrypt certificate is being detected points to an IP address that belongs to a different provider. We suggest you bring the issue to the technical team managing the remote server of this IP address. Alternatively, you can consider hosting the subdomain with SiteGround, and point it to us by changing existing CNAME for the sub domain to an A record which points to your account’s IP address, visible under cPanel.
For further assistance, please update ticket 3233215 after you hear back from the remote IP address remote host provider.

Regards,
SiteGround Team

Thanks to all that have offered help and the SiteGround support team for being very patient and going round this several times.

My Clicktracking software RedTrack now agree that the issue is there and we are working to resolve.

It has taken too many days but I have learned several lessons!

Regards

Colin

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.